Bug #10324 Updated: reproducable seg fault during generic script exec with pgsql and mcrypt
| From: | derick@php.net | Date: | Sat, 14 Apr 2001 11:38:45 +0000 |
| Subject: | Bug #10324 Updated: reproducable seg fault during generic script exec with pgsql and mcrypt | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-51567@lists.php.net to get a copy of this message | ||
ID: 10324
Updated by: derick
Reported By: kpw@jump9.com
Old-Status: Open
Status: Feedback
Bug Type: Reproduceable crash
PHP Version: 4.0.4pl1
Assigned To:
Comments:
Can you try configuring php with --enable-debug, so that better backtraces can be made?
Previous Comments:
---------------------------------------------------------------------------
[2001-04-14 00:19:26] kpw@jump9.com
Hi,
I've managed to uncover a reproducable segmentation fault that occurs during execution of a
script containing a loop of pgsql mcrypt calls. As best as I can tell mcrypt doesn't appear to
by the cuplrit as removing the mcrypt calls doesn't prent the segfault (although it does seem
to change the time/position) when the crash happens. Commententing out the Db queries (implemented
using PEAR DB) does prevent the crash, however, on several occausions I managed to get the script to
crash after my code had completed and the send buffer had been flushed (only record of a fault was
in the error log), so I'm doubtful that the error is in the db code per se.
Running gdb seems to show that memory is courupt before the script is run the first time (after
researting apache) as can be seen in the trace below (this first memory error is exposed when
executing any other script after an apache restart). Once the script runs for a while (it contains
a rather expensive loop of db calls) it fails with the seg fault.
I've already rebuilt postgres, libmcrypt and php, to no avail...
Any ideas would be most appricated!
Thanks
Kevin
---
build flags:
'./configure' '--prefix=/etc/php' '--with-apxs=/etc/apache/bin/apxs'
'--with-mysql' '--with-pgsql' '--with-mcrypt'
----
gdb session:
This GDB was configured as "ppc-yellowdog-linux"...
(gdb) run -X
Starting program: /etc/apache/bin/httpd -X
Cannot access memory at address 0x34623731.
(gdb) bt
#0 _dl_debug_state () at dl-debug.c:56
#1 0xfea2044 in dl_open_worker (a=0x30026c70) at dl-open.c:195
#2 0xfea21f8 in _dl_open (file=0xfea1d44 "224!ÿÀ|b