Bug #10073 Updated: ODBC MS ACCESS and field size

From: Date: Tue, 17 Apr 2001 02:44:09 +0000
Subject: Bug #10073 Updated: ODBC MS ACCESS and field size
Groups: php.dev 
Request: Send a blank email to php-dev+get-51745@lists.php.net to get a copy of this message
ID: 10073 Updated by: kalowsky Reported By: shazlista@usa.net Old-Status: Open Status: Closed Bug Type: ODBC related PHP Version: 4.0.4pl1 Assigned To: Comments: i am unable to reproduce this in the latest cvs builds. your sample script executes fine. please check the latest 4.0.5 RC or the latest CVS. if this is still valid please re-open the bug (change it's status). Previous Comments: --------------------------------------------------------------------------- [2001-03-29 23:45:02] shazlista@usa.net for some reason, in ms access and mdac_typ.exe 2.6 on winnt or win2k, if you try to exec query that has operation on more than 1 text field, it returns huge field size which prevents the script from executing. ex. $q="select firstName + ' ' + LastName from Students"; odbc_exec($c,$q); // if you trace the odbc function calles: call SQLColAttributes with <SQL_COLUMN_DISPLAY_SIZE> returns SQLColAttributes with return code 0 (SQL_SUCCESS) SQLLEN * 0x0012F568 (2147483598) so php_odbc.c in php4dll will assume that this field requires (2GB ) memory hence exits with error. It seems like it is an odbc bug but php engine should be aware and not exceed max size limit(say 65k or be defined in the ini/conf file) for a field. --------------------------------------------------------------------------- ATTENTION! Do NOT reply to this email! To reply, use the web interface found at http://bugs.php.net/?id=10073&edit=2

« previous php.dev (#51745) next »