Bug #1340 Updated: libphp.so: cannot load library
| From: | Bug Database | Date: | Wed, 21 Apr 1999 16:15:48 +0000 |
| Subject: | Bug #1340 Updated: libphp.so: cannot load library | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-5179@lists.php.net to get a copy of this message | ||
ID: 1340
User Update by: edward@interlook.com
Status: Open
Bug Type: Dynamic loading related
Description: libphp.so: cannot load library
I submitted bug report 1339 Anyway. With a hint from the PHP bug team (thank you very much) I was
able to solve the problem.
if you got this error:
Cannot load /usr/local/apache/libexec/libphp3.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/libphp3.so: symbol
__udivdi3: referenced symbol not found
then If you link libphp.so with -lgcc under solaris then it works fine...
is it possible to make the configure script automatically detect this and
add this LD_FLAG to the compilation process.
I already fixed it on my system, but I am thinking for other people.
Full Bug description available at: http://bugs.php.net?id=1340
--
PHP Development Mailing List http://www.php.net/
To unsubscribe send an empty message to php-dev-unsubscribe@lists.php.net
For help: php-dev-help@lists.php.net