Regression testing patterns in HTTP headers, e.g. for SetCookie(); control-file format changed

From: Date: Sun, 23 Aug 1998 03:38:09 +0000
Subject: Regression testing patterns in HTTP headers, e.g. for SetCookie(); control-file format changed
Groups: php.dev 
Request: Send a blank email to php-dev+get-518@lists.php.net to get a copy of this message
See CVS log entries for details. Basically there is a new section --HEAD-- in the test-control file which lets you to HTTP matching against a Perl pattern that's in there. In regtests/func/006.ph{tml,p3t} there is a real simple test of SetCookie(). Others are welcome to modify and make more rigourous tests. 005.ph{tml,p3t} was taken from test/general_functions, but the directory name is too long for braindead OS's and also given that there was only one function, I'm not sure what the distinction is and if it makes all that much sense. So as to distinguish the new format test file from the old, --TEST-- has been changed to --TITLE--. Comments using -- are now allowed in the test control file too. I also considered changing the file extension from php3t to something else. Dunno. And of more tests have been converted over. Lots more work could/should be done and I invite others to contribute. Not sure if I mentioned, but regtests/strings/00{2,3}.* don't work for me. I'm curious if they do for others. -- PHP Development Mailing List http://www.php.net/ To unsubscribe send an empty message to php-dev-unsubscribe@lists.php.net For help: php-dev-help@lists.php.net

« previous php.dev (#518) next »