PHP 4.0 Bug #10397 Updated: Cannot get, set or walk on different subtree than .iso.3.6.1.2.1

From: Date: Thu, 19 Apr 2001 18:16:29 +0000
Subject: PHP 4.0 Bug #10397 Updated: Cannot get, set or walk on different subtree than .iso.3.6.1.2.1
Groups: php.dev 
Request: Send a blank email to php-dev+get-51999@lists.php.net to get a copy of this message
ID: 10397 User Update by: tlechat@ccf.com Status: Open Bug Type: SNMP related Description: Cannot get, set or walk on different subtree than .iso.3.6.1.2.1 PRECISION : In my previous mail I wrote that snmpget("myhost","public","1.3.6.1.2.3.1191.1.2") will fails with warning ".iso.3.6.1.2.1.1.3.6.1.2.3.1191.1.2" doesn't exists But the exact warning is : Warning: Invalid object identifier: 1.3.6.1.2.3.1191.1.2 So it could be really an incorrect object identifier, but a simple snmpwalkoid on same machine can show you that it starts always on iso.3.6.1.2.1. if you specify no OID, and it fails if you specify OID (for example try with .1 or .iso) Please note that my correct email is tlechat@ccf.fr (sorry) Regards Previous Comments: --------------------------------------------------------------------------- [2001-04-19 07:09:31] tlechat@ccf.com If seems that a default OID (.iso.3.6.1.2.1) is always added to OID parameter when I call snmpget or snmpwalk. Example, If I try : snmpget("myhost","public","1.3.6.1.2.3.1191.1.2"), it will try to get .iso.3.6.1.2.1.1.3.6.1.2.3.1191.1.2 so it fails.... with warning ".iso.3.6.1.2.1.1.3.6.1.2.3.1191.1.2" doesn't exists I modify php_snmp.dll when I saw with an dll editor the string .1.3.6.1.2.1 inside and I replace first of his char by

« previous php.dev (#51999) next »