Bug #8631 Updated: Unreadable error message when unable to connect to IBM DB2

From: Date: Mon, 23 Apr 2001 03:00:24 +0000
Subject: Bug #8631 Updated: Unreadable error message when unable to connect to IBM DB2
Groups: php.dev 
Request: Send a blank email to php-dev+get-52165@lists.php.net to get a copy of this message
ID: 8631 Updated by: kalowsky Reported By: massimo.ferrario@inforeti.it Old-Status: Open Status: Bogus Bug Type: ODBC related PHP Version: 4.0.4 Assigned To: Comments: if you've poorly installed your DB, theres very little PHP can do. Previous Comments: --------------------------------------------------------------------------- [2001-01-10 07:36:22] massimo.ferrario@inforeti.it I am trying to work with RH6.2 + Apache1.3.14 + PHP 4.0.4 on a machine where someone else (mis)installed IBM DB2 version 7.1 for linux. I compiled PHP as a DSO using the --with-ibm-db2 switch. Apparently the did not correctly setup the environment to make DB2 setup available for the Apache process: when i try to connect to DB2 using odbc_connect() I get "binary trash" inside the warning i get from PHP. I think that "trash" appears where the error message from DB2 should appear instead. If i restart the apache process after setting up the required DB2 environment variables for user root (i.e. now I can connect to DB2 as root) everithing works ok: i.e., if I connect to a non-existant DB I get 'readable' error message instead of trash. --------------------------------------------------------------------------- ATTENTION! Do NOT reply to this email! To reply, use the web interface found at http://bugs.php.net/?id=8631&edit=2

« previous php.dev (#52165) next »