Bug #9612 Updated: iPlanet 4.0 SP3 install obj.conf
| From: | avsm@php.net | Date: | Wed, 25 Apr 2001 17:22:57 +0000 |
| Subject: | Bug #9612 Updated: iPlanet 4.0 SP3 install obj.conf | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-52402@lists.php.net to get a copy of this message | ||
ID: 9612
Updated by: avsm
Reported By: bdgregg@pitt.edu
Old-Status: Open
Status: Feedback
Bug Type: iPlanet related
PHP Version: 4.0 Latest CVS (07/03/2001)
Assigned To:
Comments:
Try the following obj.conf entry, and see if it fixes your problem. Apart from this change, you
should follow the manual entry for the rest of the obj.conf
Init fn="load-modules" shlib="/path/to/server4/bin/libphp4.so"
funcs="php4_init,php4_close,php4_execute,php4_auth_trans"
Init fn="php4_init" LateInit="yes"
Previous Comments:
---------------------------------------------------------------------------
[2001-03-07 22:16:54] bdgregg@pitt.edu
Seems no matter what version of 4.0.4 (where I started) and up I can not get the Netscape/iPlanet
Enterprise server 4.0 SP3 to load properly. We are currently using version 3.x in cgi mode and
would like it embeded if possible. I have seen similar problems but with no real solution posted.
I will eventually need to add Oracle, Mysql, and LDAP modules included but since I couldn't get
it to work, I decided to limit what was being included in the nsapi module. I think I have limited
it to as little as possible. The following is what I last tried and it still did not work. If I
remove the lines from the obj.conf file that references the php module the server starts with out a
problem. I also modified the start script to include the LD_LIBRARY_PATH additional directories so
they should not be the problem. The Error log reports nothing out of the ordinary.
Try a basic configure... (using hints I found in the bug database - I am assuming the following is
correct)
./configure --with-nsapi=/usr/local/netscape/server4 --without-mysql --enable-libgcc
--enable-experimental-zts
configure completes no problem.
make... compiles. Except I notice...
nsapi.c: In function `nsapi_request_dtor':
nsapi.c:440: warning: passing arg 1 of `nsapi_free' discards qualifiers from pointer target
type
nsapi.c:442: warning: passing arg 1 of `nsapi_free' discards qualifiers from pointer target
type
I ignore the warnings...
make install... Installs no errors.
Using Administration web port I attempt to start the server but every time it returns the following:
Status:
[https-phphelpdesk]: start failed. (2: unknown early startup error)
[https-phphelpdesk]: server terminated (signal 6): watchdog is restarting it
[https-phphelpdesk]: failure: server initialization failed
Error
An error occurred during startup.
The server https-phphelpdesk was not started.
I would like to use the php module. Please, if anyone knows any working configurations of iPlanet
Enterprise Server on Solaris working with PHP 4.x let me know how you did it.
Thanks,
Brian Gregg
University of Pittsburgh
University Library System
Pittsburgh, PA 15260
---------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=9612&edit=2