Bug #7376 Updated: startup fails with undefined symbol: SSL_CTX_set_tmp_rsa_callback
| From: | sniper@php.net | Date: | Sat, 28 Apr 2001 00:59:11 +0000 |
| Subject: | Bug #7376 Updated: startup fails with undefined symbol: SSL_CTX_set_tmp_rsa_callback | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-52668@lists.php.net to get a copy of this message | ||
ID: 7376
Updated by: sniper
Reported By: andras@izone.hu
Old-Status: Open
Status: Closed
Bug Type: Dynamic loading
PHP Version: 4.0.2
Assigned To:
Comments:
Update your PHP to at least 4.0.4pl1. And add --with-imap-ssl (with correct path) into your
configure line. This is not a bug in PHP. Ask further help on
php-install@lists.php.net
--Jani
Previous Comments:
---------------------------------------------------------------------------
[2000-10-20 17:08:16] andras@izone.hu
Tried MySQL connection with an out-of-the-box redhat 7.0 installation with apache (ssl support),
their build of php, and their distro of mysql. It failed. I decided to recompile PHP 4.0.2 on the
box, and upon trying to run it:
Cannot load /usr/local/apache/libexec/libphp4.so into server: undefined symbol:
SSL_CTX_set_tmp_rsa_callback
Then compiled a pristine apache 1.3.12 without ssl support, tried compiling php against it, and yet
it gives the same result. What is it?
-p
info: PHP configured with:
--with-apxs=/usr/local/apache/bin/apxs --enable-dbase --with-kerberos --with-gd --with-ttf
--with-imap --with-mysql --enable-trans-sid --enable-sockets --enable-sysvsem --enable-sysvshm
--with-zlib --enable-memory-limit --with-regex=php
---------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=7376&edit=2