Bug #8888 Updated: Authentication in iPlanet Fails
| From: | jmoore@php.net | Date: | Sun, 29 Apr 2001 15:48:04 +0000 |
| Subject: | Bug #8888 Updated: Authentication in iPlanet Fails | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-52929@lists.php.net to get a copy of this message | ||
ID: 8888
Updated by: jmoore
Reported By: dylan@realcafes.com
Old-Status: Feedback
Status: Closed
Bug Type: iPlanet related
PHP Version: 4.0.4pl1
Assigned To:
Comments:
No feedback.
closing
Previous Comments:
---------------------------------------------------------------------------
[2001-03-29 09:51:53] sniper@php.net
Does this happen with latest CVS snapshot from http://snaps.php.net/ ?
--Jani
---------------------------------------------------------------------------
[2001-01-24 12:50:42] dylan@realcafes.com
Have PHP4 compiled and installed as an NSAPI module into iPlanet Enterprise Server 4.1. PHP scripts
work fine and dandy, with the exception of authorization. When my PHP script runs, the pop-up
appears, and I enter my user name and password. From there, the system acts like the cancel button
has been clicked.
I've figured out that no matter what happens, PHP_AUTH_USER and PHP_AUTH_PW (the two variables
that my script uses to process logins) aren't being set. A quick check of the docs confirms
that (I think) I've got everything correct. Here's my obj.conf file:
# Sun Netscape Alliance - obj.conf
# You can edit this file, but comments and formatting changes
# might be lost when the admin server makes changes.
Init fn="flex-init"
access="/system/netscape/server4/https-https.www.cafefortwo.com/logs/access"
format.access="%Ses->client.ip% - %Req->vars.auth-user% [%SYSDATE%]
"%Req->reqpb.clf-request%"
%Req->srvhdrs.clf-status% %Req->srvhdrs.content-length%"
Init fn="load-types" mime-types="mime.types"
Init fn="load-modules" funcs="php4_init,php4_close,php4_execute,php4_auth_trans"
shlib="/system/netscape/server4/bin/libphp4.so"
Init fn="php4_init" errorString="Failed to initialise PHP!"
<Object name="default">
AuthTrans fn="php4_auth_trans"
NameTrans fn="document-root" root="/system/server/cf2/root"
PathCheck fn="unix-uri-clean"
PathCheck fn="find-pathinfo"
PathCheck fn="find-index"
index-names="index.php,home.php,index.php3,home.php3,index.html,home.html"
ObjectType fn="type-by-extension"
ObjectType fn="force-type" type="text/plain"
Service fn="php4_execute" type="magnus-internal/x-httpd-php"
Service method="(GET|HEAD)" type="magnus-internal/imagemap"
fn="imagemap"
Service method="(GET|HEAD)" type="magnus-internal/directory"
fn="index-common"
Service method="(GET|HEAD)" type="*~magnus-internal/*" fn="send-file"
AddLog fn="flex-log" name="access"
</Object>
<Object name="x-httpd-php">
ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
Service fn="php4_execute"
</Object>
Is this a PHP bug or an iPlanet problem? Any help would be greatly appreciated.
---------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=8888&edit=2