Bug #9936 Updated: Unable to register functions when starting apache
| From: | jmoore@php.net | Date: | Sun, 29 Apr 2001 15:49:05 +0000 |
| Subject: | Bug #9936 Updated: Unable to register functions when starting apache | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-52931@lists.php.net to get a copy of this message | ||
ID: 9936
Updated by: jmoore
Reported By: ryan@the-summit.net
Old-Status: Feedback
Status: Closed
Bug Type: Apache related
PHP Version: 4.0.4pl1
Assigned To:
Comments:
No feedback.
closing
Previous Comments:
---------------------------------------------------------------------------
[2001-03-26 16:19:24] sniper@php.net
Was PHP3 (or PHP 4) compiled as static module into Apache?
It might explain this rather odd behaviour.
--Jani
---------------------------------------------------------------------------
[2001-03-22 13:01:35] ryan@the-summit.net
compile options:
./configure
--with-apxs=/usr/sbin/apxs
--enable-versioning
--with-mysql
--enable-track-vars
--with-imap-ssl=/usr/lib/ssl
It compiles fine with no errors.
I commented all references to php3 out of httpd.conf
when I try to start apache, the error_log reports:
PHP Warning: Function registration failed - duplicate name - define in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - defined in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - each in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - strlen in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - strcmp in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - strcasecmp in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - error_reporting in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - leak in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - function_exists in Unknown on line 0
PHP Warning: Basic Functions: Unable to register functions, unable to load in Unknown on line 0
I have seen simlear errors to mine in the bug database, but none of the solutions seem to apply to
my problem. Something with SuSE 7.1??
---------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=9936&edit=2