Bug #10617: DSO won't load
| From: | loosecannon at 411 dot com | Date: | Wed, 02 May 2001 19:38:40 +0000 |
| Subject: | Bug #10617: DSO won't load | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-53419@lists.php.net to get a copy of this message | ||
From: loosecannon@411.com
Operating system: Solaris 2.6
PHP version: 4.0.5
PHP Bug Type: Apache related
Bug description: DSO won't load
I configured PHP with the following:
./configure --with-apxs=/www/server/apache/bin/apxs --with-yaz=/www/src/yaz-1.6
--with-sybase=/usr/local/sybase/client --with-xml --enable-ftp --with-gd=/www/src/gd1.2
--disable-pear --with-dbase --enable-libgcc --enable-freetype-4bit-antialias-hack
--with-pdflib=/www/src/pdflib-3.03 --with-tiff-dir=/www/src/tiif-v3.4
--with-png-dir=/www/src/libpng-1.0.9 --enable-sockets --with-zlib-dir=/www/src/zlib-1.1.3
--enable-versioning --enable-libgcc
and all goes well through the make process. However when I got to restart Apache (1.3.09) I get the
following error:
Syntax error on line 233 of /www/server/apache/conf/httpd.conf:
Cannot load /www/server/apache/libexec/libphp4.so into server: ld.so.1: /www/server/apache
/bin/httpd: fatal: relocation error: file /www/server/apache/libexec/libphp4.so: symbol hstrerror:
referenced symbol not found
When I do an ldd for the libphp4.so I get the following:
ldd libphp4.so
libpam.so.1 => /usr/lib/libpam.so.1
libdl.so.1 => /usr/lib/libdl.so.1
libnsl.so.1 => /usr/lib/libnsl.so.1
libsocket.so.1 => /usr/lib/libsocket.so.1
libsybdb.so => /usr/lib/libsybdb.so
libresolv.so.2 => /usr/lib/libresolv.so.2
libm.so.1 => /usr/lib/libm.so.1
libc.so.1 => /usr/lib/libc.so.1
libmp.so.2 => /usr/lib/libmp.so.2
/usr/platform/SUNW,Ultra-4/lib/libc_psr.so.1
--
Edit Bug report at: http://bugs.php.net/?id=10617&edit=1