PHP 4.0 Bug #10619 Updated: Apache is not able to load the php module
| From: | sonnysavage at yahoo dot com | Date: | Thu, 03 May 2001 14:06:04 +0000 |
| Subject: | PHP 4.0 Bug #10619 Updated: Apache is not able to load the php module | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-53615@lists.php.net to get a copy of this message | ||
ID: 10619
User Update by: sonnysavage@yahoo.com
Old-Status: Closed
Status: Open
Bug Type: Apache related
Description: Apache is not able to load the php module
I tried again, and here are the steps that I took:
1) I uninstalled and removed all files for both PHP and Apache.
2) I unzipped PHP 4.0.5, copied the "php.ini-dist" to "php.ini" in my WinNT
folder, Rebooted, Installed Apache 1.3.19, added this line to my httpd.conf file "LoadModule
php4_module c:/php/sapi/php4apache.dll" (as well as other configurations).
3) When starting Apache, I get the exact same error as before.
4) I replaced the 4.0.5 version of the php4apache.dll with the 4.0.4pl1 version, and Apache started
without a hitch.
Previous Comments:
---------------------------------------------------------------------------
[2001-05-03 06:22:02] dbeu@php.net
unable to repsoduce in the same environment.
i guess you haven't replaced everything with the new build.
---------------------------------------------------------------------------
[2001-05-02 16:35:00] sonnysavage@yahoo.com
I have PHP being loaded as an Apache module. I am using Apache 1.3.19. I am using the standard
Win32 binary release for both PHP and Apache.
Here is the line from my httpd.conf file:
LoadModule php4_module c:/php/sapi/php4apache.dll
I get this error message when trying to start apache:
=====================================================
Syntax error on line 182 of c:/program files/apache group/apache/httpd.conf:
Cannot load c:/php/sapi/php4apache.dll into server: (127) The specified procedure could not be
found:
Note the errors or messages above, and press the (ESC) key to exit.
=====================================================
If I replace the 4.0.5 dll with version 4.0.4pl1, it works just fine.
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=10619