Bug #10619 Updated: Apache is not able to load the php module
| From: | cynic@php.net | Date: | Thu, 03 May 2001 15:20:20 +0000 |
| Subject: | Bug #10619 Updated: Apache is not able to load the php module | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-53639@lists.php.net to get a copy of this message | ||
ID: 10619
Updated by: cynic
Reported By: sonnysavage@yahoo.com
Old-Status: Closed
Status: Bogus
Bug Type: Apache related
PHP Version: 4.0.5
Assigned To:
Comments:
you don't need to have php4ts.dll in windows/system/, just leave it in the directory where
apache.exe is.
Zend Optimizer is a third party product, report the errors to Zend.
Previous Comments:
---------------------------------------------------------------------------
[2001-05-03 11:11:12] sonnysavage@yahoo.com
Here is a link to a similar thread on phpbuilder.com:
http://www.phpbuilder.com/forum/read.php3?num=3&id=104846&loc=0&thread=104846
---------------------------------------------------------------------------
[2001-05-03 11:09:26] sonnysavage@yahoo.com
I have solved the problem. I didn't copy the new php4ts.dll to my sys directory.
Another problem however is that the Zend optimizer doesn't work. I have version 1.1.0 and it
gives me a pile of errors. I commented the zend lines out of my php.ini, and the php apache module
loads fine now.
---------------------------------------------------------------------------
[2001-05-03 10:06:03] sonnysavage@yahoo.com
I tried again, and here are the steps that I took:
1) I uninstalled and removed all files for both PHP and Apache.
2) I unzipped PHP 4.0.5, copied the "php.ini-dist" to "php.ini" in my WinNT
folder, Rebooted, Installed Apache 1.3.19, added this line to my httpd.conf file "LoadModule
php4_module c:/php/sapi/php4apache.dll" (as well as other configurations).
3) When starting Apache, I get the exact same error as before.
4) I replaced the 4.0.5 version of the php4apache.dll with the 4.0.4pl1 version, and Apache started
without a hitch.
---------------------------------------------------------------------------
[2001-05-03 06:22:02] dbeu@php.net
unable to repsoduce in the same environment.
i guess you haven't replaced everything with the new build.
---------------------------------------------------------------------------
[2001-05-02 16:35:00] sonnysavage@yahoo.com
I have PHP being loaded as an Apache module. I am using Apache 1.3.19. I am using the standard
Win32 binary release for both PHP and Apache.
Here is the line from my httpd.conf file:
LoadModule php4_module c:/php/sapi/php4apache.dll
I get this error message when trying to start apache:
=====================================================
Syntax error on line 182 of c:/program files/apache group/apache/httpd.conf:
Cannot load c:/php/sapi/php4apache.dll into server: (127) The specified procedure could not be
found:
Note the errors or messages above, and press the (ESC) key to exit.
=====================================================
If I replace the 4.0.5 dll with version 4.0.4pl1, it works just fine.
---------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view the rest of the comments,
please view the bug report online.
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=10619&edit=2