PHP 4.0 Bug #10619 Updated: Apache is not able to load the php module
| From: | sonnysavage at yahoo dot com | Date: | Thu, 03 May 2001 15:44:10 +0000 |
| Subject: | PHP 4.0 Bug #10619 Updated: Apache is not able to load the php module | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-53650@lists.php.net to get a copy of this message | ||
ID: 10619
User Update by: sonnysavage@yahoo.com
Status: Bogus
Bug Type: Apache related
Description: Apache is not able to load the php module
I have isolated the cause of the problem(at least my problem).
In my case, I commented out the following line in php.ini
extension=php_mssql70.dll
Then the Apache crash does not happpen.
Hope this helps
Previous Comments:
---------------------------------------------------------------------------
[2001-05-03 11:20:20] cynic@php.net
you don't need to have php4ts.dll in windows/system/, just leave it in the directory where
apache.exe is.
Zend Optimizer is a third party product, report the errors to Zend.
---------------------------------------------------------------------------
[2001-05-03 11:11:12] sonnysavage@yahoo.com
Here is a link to a similar thread on phpbuilder.com:
http://www.phpbuilder.com/forum/read.php3?num=3&id=104846&loc=0&thread=104846
---------------------------------------------------------------------------
[2001-05-03 11:09:26] sonnysavage@yahoo.com
I have solved the problem. I didn't copy the new php4ts.dll to my sys directory.
Another problem however is that the Zend optimizer doesn't work. I have version 1.1.0 and it
gives me a pile of errors. I commented the zend lines out of my php.ini, and the php apache module
loads fine now.
---------------------------------------------------------------------------
[2001-05-03 10:06:03] sonnysavage@yahoo.com
I tried again, and here are the steps that I took:
1) I uninstalled and removed all files for both PHP and Apache.
2) I unzipped PHP 4.0.5, copied the "php.ini-dist" to "php.ini" in my WinNT
folder, Rebooted, Installed Apache 1.3.19, added this line to my httpd.conf file "LoadModule
php4_module c:/php/sapi/php4apache.dll" (as well as other configurations).
3) When starting Apache, I get the exact same error as before.
4) I replaced the 4.0.5 version of the php4apache.dll with the 4.0.4pl1 version, and Apache started
without a hitch.
---------------------------------------------------------------------------
[2001-05-03 06:22:02] dbeu@php.net
unable to repsoduce in the same environment.
i guess you haven't replaced everything with the new build.
---------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view the rest of the comments,
please view the bug report online.
Full Bug description available at: http://bugs.php.net/?id=10619