Bug #8376 Updated: IPlanet 4.1 fails to load PHP module
| From: | avsm@php.net | Date: | Thu, 03 May 2001 19:39:06 +0000 |
| Subject: | Bug #8376 Updated: IPlanet 4.1 fails to load PHP module | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-53698@lists.php.net to get a copy of this message | ||
ID: 8376
Updated by: avsm
Reported By: riddell@btv.ibm.com
Old-Status: Feedback
Status: Closed
Bug Type: iPlanet related
PHP Version: 4.0.4
Assigned To:
Comments:
no feedback
Previous Comments:
---------------------------------------------------------------------------
[2001-04-25 13:24:03] avsm@php.net
Try the following obj.conf entry, and see if it fixes your problem. Apart from this change, you
should follow the manual entry for the rest of the obj.conf
Init fn="load-modules" shlib="/path/to/server4/bin/libphp4.so"
funcs="php4_init,php4_close,php4_execute,php4_auth_trans"
Init fn="php4_init" LateInit="yes"
---------------------------------------------------------------------------
[2000-12-22 09:29:37] riddell@btv.ibm.com
I am having the same problem as described in bug report 5536. libphp4.so seems to be compiling as a
Netscape ES 3.x plugin, which loads ns-httpd functions at module initialization as opposed to
IPlanet 4.x which loads them at runtime. Tried using Netscape provided script to relink libphp4.so
to load ns-httpd symbols at runtime to no avail (script failed). Netscape claims changes need to be
made to the Makefile to get plugins to link properly. I am not sure how to do this. Here's
IPWS output:
[https-fradkin.btv.ibm.com]: start failed. (2: unknown early startup error)
[https-fradkin.btv.ibm.com]: conf_init: Error running init function load-modules: dlopen of
/web/iplanet/es.4.1sp5/bin/libphp4.so failed (
0509-130 Symbol resolution failed for /web/iplanet/es.4.1sp5/bin/libphp4.so because:
[https-fradkin.btv.ibm.com]: 0509-136 Symbol __builtin_delete (number 198) is not exported
from
[https-fradkin.btv.ibm.com]: dependent module ns-httpd.
[https-fradkin.btv.ibm.com]: 0509-136 Symbol __rtti_si (number 199) is not exported from
[https-fradkin.btv.ibm.com]: dependent module ns-httpd.
[https-fradkin.btv.ibm.com]: 0509-136 Symbol __rtti_user (number 200) is not exported from
[https-fradkin.btv.ibm.com]: dependent module ns-httpd.
[https-fradkin.btv.ibm.com]: 0509-192 Examine .loader section symbols with the
[https-fradkin.btv.ibm.com]: 'dump -Tv' command.)
[https-fradkin.btv.ibm.com]: server exit: status 1
PHP configured with --with-mysql=/pathtomysql --enable-libgcc --with-nsapi=/pathtoiplanet
Thanks!
---------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=8376&edit=2