Bug #6922 Updated: Cannot load /etc/httpd/modules/libphp4.so into server

From: Date: Sun, 06 May 2001 15:13:14 +0000
Subject: Bug #6922 Updated: Cannot load /etc/httpd/modules/libphp4.so into server
Groups: php.dev 
Request: Send a blank email to php-dev+get-54104@lists.php.net to get a copy of this message
ID: 6922 Updated by: derick Reported By: kiment@addr.com Old-Status: Open Status: Feedback Bug Type: Dynamic loading Operating system: PHP Version: 4.0.2 Assigned To: Comments: Can you try this with php 4.0.5 and see if this problem still exists? Previous Comments: --------------------------------------------------------------------------- [2000-09-28 06:27:16] kiment@addr.com I have the following configuration options for dynamic php: sh ./configure --prefix=/usr --without-gd --with-apxs=/usr/sbin/apxs --enable-versioning --with-config-file-path=/usr/lib --enable-debugger=yes --enable-safe-mode --with-exec-dir=/usr/bin --with-mysql --with-oci8=/u01/app/oracle/product/8.1.5 --with-pdflib=/usr --with-system-regex --enable-track-vars --with-ttf --with-zlib --with-wddx This configures and compiles fine. I configured the httpd.conf files with the appropriate module paths... LoadModule php4_module modules/libphp4.so AddModule mod_php4.c Since I'm running oracle 8.1.5.01(with patches) for linux, I even made sure the LD_LIBRARY_PATH was available for apache LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/u01/app/oracle/product/8.1.5/lib export LD_LIBRARY_PATH Then I start apache... /usr/local/apache/bin/apachectl start However, this is the error I get every time. [root@redora init.d]# ./httpd start Starting httpd: Syntax error on line 874 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp 4.so: undefined symbol: php_regcomp [FAILED] [root@redora init.d]# I believe this problem involves how php4's routine interfaces with the oracle sqlplus calls although I'm not too sure exactly where it breaks. --------------------------------------------------------------------------- ATTENTION! Do NOT reply to this email! To reply, use the web interface found at http://bugs.php.net/?id=6922&edit=2

« previous php.dev (#54104) next »