Bug #10786: localhost now fails in mysql_(p)connect
| From: | davidv at angliaed dot co dot uk | Date: | Thu, 10 May 2001 12:44:13 +0000 |
| Subject: | Bug #10786: localhost now fails in mysql_(p)connect | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-54676@lists.php.net to get a copy of this message | ||
From: davidv@angliaed.co.uk
Operating system: Linux SuSE 7.1/Mandrake 7.2
PHP version: 4.0.5
PHP Bug Type: MySQL related
Bug description: localhost now fails in mysql_(p)connect
Two systems have been upgraded from 4.0.4pl1 to 4.0.5 and both have then failed to connect to a
MySQL database using 'localhost' in the mysql_connect or mysql_pconnect calls. The MySQL
installation has not been upgraded. Replacing the libphp4.so with the 4.0.4pl1 version and
restarting apache fixes the problem as does changing 'localhost' to '127.0.0.1'
(plus a similar mod to mysql db and user tables in the database so that the host names match).
The MySQL version is 3.23.32
--
Edit Bug report at: http://bugs.php.net/?id=10786&edit=1