Re: AW: [PHP-DEV] 4.1 & Declaration Case Persistance

From: Date: Thu, 10 May 2001 14:40:33 +0000
Subject: Re: AW: [PHP-DEV] 4.1 & Declaration Case Persistance
Groups: php.dev 
Request: Send a blank email to php-dev+get-54709@lists.php.net to get a copy of this message
"Sterling Hughes" <sterling@designmultimedia.com> schrieb im Newsbeitrag news:<Pine.LNX.4.30.0105091426140.1022-100000@localhost.localdomain>... > On Thu, 10 May 2001, Jani Taskinen wrote: > > > On Wed, 9 May 2001, Sterling Hughes wrote: > > > > >On Thu, 10 May 2001, Jani Taskinen wrote: > > >> This is just because some developers don't like to follow the guidelines. > > >> As, I quote, "it woulnd't be fun anymore" or "you can't > > >> force anyone". > > > > > >Hrrmmm.. Which guidelines would those be? And no, you can't force anyone, > > > > This one.. (from CODING_STANDARDS): > > > > ----8<--------------------------------------- > > Naming Conventions > > ------------------ > > > > [1] Function names for user-level functions should be enclosed with in > > the PHP_FUNCTION() macro. They should be in lowercase, with words > > --------8<----------------------------------- yea, but i wasn't talking about functions, i was talking about classes (in particular the com, dotnet and variant class). i couldn't find a guidline how to name classes, attributes or methods. there is even no guidline in the PEAR CODING_STANDARDS file, but they use a more c++ like convention: CLASS->lowerUpperUpper(); should this be adopted to have an uniform convetion ? any other ideas ? and at least, how should they be documented in the php documentation (i posted a mail 2 days ago, but without response) ? afaik there is only a <function></function> tag, but no <class></class>, <member></member>, <method></method>, <constructor></constructor>, etc. tags. any suggestions ? > > > > And yes, you can force anyone. If they don't follow the guidelines set, > > their CVS access can as easily be taken from them as it was given.. > > This is same as if someone intentionally breaks some parts of the code. > > i didn't want to blame someone, the reason i asked was, that the com extension was originaly done by zeev, so i thought there was a reason for the naming.

« previous php.dev (#54709) next »