Bug #10821: Web server won't start after php make install
| From: | eggrant at aol dot com | Date: | Fri, 11 May 2001 22:36:37 +0000 |
| Subject: | Bug #10821: Web server won't start after php make install | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-54913@lists.php.net to get a copy of this message | ||
From: eggrant@aol.com
Operating system: Solaris 2.7 & Solaris 2.8
PHP version: 4.0.5
PHP Bug Type: *Install and Config
Bug description: Web server won't start after php make install
I am trying to configure PHP4 to be used with Netscape Enterprise 3.6 with NSAPI, LDAP, and
SYBASE-CT on a Solaris 2.7 machine.
The error from the NES admin tool is
pclose() failed. (2: unknown early startup error)
Error
An error occurred during startup.
The server https-<server> was not started.
PHP4.0.5 compile is successfull with the following configuration:
./configure --with-nsapi=/opt/netscape/suitspot --with-ldap=/usr/local/ldap
--with-sybase=/usr/syb119/11.1.1 --enable-track-vars --enable-libgcc
I have completed the PHP4 install steps mentioned on:
http://www.php.net/manual/en/install.netscape-enterprise.ph
I have verified clean tests from the Netscape bug report with Netscape Engineers:
http://help.netscape.com/kb/corporate/19990524-10.html
If I comment out the following line from the obj.conf file the server will start as expected.
Init fn="load-modules" funcs="php4_init,php4_close,php4_execute,php4_auth_tr
ans" shlib="/opt/netscape/suitspot/bin/libphp4.so"
My previous PHP install without the LDAP and Sybase extensions worked just fine. Problem is that I
need the LDAP and Sybase modules.
I have attempted this with Solaris 2.8 and iPlanet Webserver 4.1 SP7 with the same problems.
Anyone have any ideas?
Take Care,
Eric G. Grant
--
Edit Bug report at: http://bugs.php.net/?id=10821&edit=1