Bug #10969 Updated: apache don't start, cannot load php4apache.dll
| From: | jmoore@php.net | Date: | Sat, 19 May 2001 14:44:27 +0000 |
| Subject: | Bug #10969 Updated: apache don't start, cannot load php4apache.dll | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-55887@lists.php.net to get a copy of this message | ||
ID: 10969
Updated by: jmoore
Reported By: ipcholkin@yahoo.com
Status: Open
Bug Type: Apache related
Operating system:
PHP Version: 4.0.5
Assigned To:
Comments:
This is not a bug in PHP. You have made a mistake in your httpd.conf on line 979. fix this syntax
error and try again.
Previous Comments:
---------------------------------------------------------------------------
[2001-05-19 10:14:54] ipcholkin@yahoo.com
When I try to start apache, it says:
"Syntax error on line 979 of k:/apache/apache/conf/httpd.conf:
Cannot load k:/apache/apache/modules/mod_php4/sapi/php4apache.dll into server: (
1157)"
Added lines in apache.conf are:
-------CUT HERE------------
# for the apache module
LoadModule php4_module modules/mod_php4/sapi/php4apache.dll
AddType application/x-httpd-php .php4
#for the cgi binary (you can use that one compiled with force cgi redirect too)
ScriptAlias /php4/ "k:/apache/apache/modules/mod_php4/"
Action application/x-httpd-php4 "/php4/php.exe"
AddType application/x-httpd-php4 .php
-------CUT HERE------------
---------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=10969&edit=2