Bug #10969 Updated: apache don't start, cannot load php4apache.dll

From: Date: Mon, 21 May 2001 07:36:13 +0000
Subject: Bug #10969 Updated: apache don't start, cannot load php4apache.dll
Groups: php.dev 
Request: Send a blank email to php-dev+get-56013@lists.php.net to get a copy of this message
ID: 10969 User Update by: ipcholkin@yahoo.com Status: Bogus Bug Type: Apache related Operating system: Win 98 PHP Version: 4.0.5 Description: apache don't start, cannot load php4apache.dll I don't see any sintax error there. Please send detailed info. I think scripting engine classifies this as a sintax error but indeed there are another kind of a problem. By the way, the full message I see in my console window is: "Syntax error on line 979 of k:/apache/apache/conf/httpd.conf: Cannot load k:/apache/apache/modules/mod_php4/sapi/php4apache.dll into server: (1157) Cannot load dinamic library:" The last sentence was written in russian, in accordance with OS-specific regional settings and then translated by me in English. That's why I omitted this message in the first edition of this bug report. Previous Comments: --------------------------------------------------------------------------- [2001-05-19 10:50:01] jmoore@php.net Bogus --------------------------------------------------------------------------- [2001-05-19 10:44:27] jmoore@php.net This is not a bug in PHP. You have made a mistake in your httpd.conf on line 979. fix this syntax error and try again. --------------------------------------------------------------------------- [2001-05-19 10:14:54] ipcholkin@yahoo.com When I try to start apache, it says: "Syntax error on line 979 of k:/apache/apache/conf/httpd.conf: Cannot load k:/apache/apache/modules/mod_php4/sapi/php4apache.dll into server: ( 1157)" Added lines in apache.conf are: -------CUT HERE------------ # for the apache module LoadModule php4_module modules/mod_php4/sapi/php4apache.dll AddType application/x-httpd-php .php4 #for the cgi binary (you can use that one compiled with force cgi redirect too) ScriptAlias /php4/ "k:/apache/apache/modules/mod_php4/" Action application/x-httpd-php4 "/php4/php.exe" AddType application/x-httpd-php4 .php -------CUT HERE------------ --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=10969

« previous php.dev (#56013) next »