Bug #8539 Updated: undefined symbol: phpi_get_le_gd
| From: | jmoore@php.net | Date: | Mon, 21 May 2001 21:08:14 +0000 |
| Subject: | Bug #8539 Updated: undefined symbol: phpi_get_le_gd | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-56128@lists.php.net to get a copy of this message | ||
ID: 8539
Updated by: jmoore
Reported By: salaj@pronixnet.sk
Old-Status: Critical
Status: Closed
Bug Type: Dynamic loading
Operating system:
PHP Version: 4.0 Latest CVS (03/01/2001)
Assigned To:
Comments:
Fixed in CVS. Please test latest snapshot.
- James
Previous Comments:
---------------------------------------------------------------------------
[2001-05-09 11:10:25] sniper@php.net
Marked as to be fixed before 4.0.6
---------------------------------------------------------------------------
[2001-04-27 22:00:02] sniper@php.net
Reopened: This is still a problem with latest CVS of today.
The general problem is that if you have functions in a shared extension that are used in other
extensions it won't
work.
--Jani
---------------------------------------------------------------------------
[2001-01-05 23:39:30] sniper@php.net
Duplicate of bug report #8437.
Removing 'shared' from the --with-gd option is a temporary workaround.
--Jani
---------------------------------------------------------------------------
[2001-01-03 14:56:41] salaj@pronixnet.sk
My configure parameters:
./configure --with-apxs=/usr/local/apache/bin/apxs --with-openssl=/usr/local/ssl --enable-calendar
--enable-ctype --enable-dbase --enable-exif --enable-filepro --enable-ftp
--with-gd=shared,/usr/local --enable-gd-imgstrttf --with-ttf=/usr/local --with-t1lib=/usr/local
--with-hyperwave --with-imap=/root/imap-2000a --with-mysql=/usr/local --with-pdflib=/usr/local
--with-tiff-dir=/usr/local --with-jpeg-dir=/usr/local --enable-trans-sid --enable-shmop
--enable-sockets --with-regex=php --enable-sysvsem --enable-sysvshm --enable-wddx --enable-yp
--with-zlib=/usr/local
Configure and make without any problems, but when I try to start Apache, I get an error:
Syntax error on line 208 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: undefined symbol: phpi_get_le_gd
./apachectl start: httpd could not be started
---------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=8539&edit=2