Bug #7016 Updated: Error when starting iPlanet
| From: | derick@php.net | Date: | Mon, 21 May 2001 22:55:15 +0000 |
| Subject: | Bug #7016 Updated: Error when starting iPlanet | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-56148@lists.php.net to get a copy of this message | ||
ID: 7016
Updated by: derick
Reported By: lester@i-quest.com
Old-Status: Feedback
Status: Closed
Bug Type: iPlanet related
Operating system:
PHP Version: 4.0.2
Assigned To:
Comments:
Closing because of no feedback
Previous Comments:
---------------------------------------------------------------------------
[2001-04-30 16:43:29] sniper@php.net
status -> feedback
---------------------------------------------------------------------------
[2001-04-30 04:43:38] avsm@php.net
Try the following obj.conf entry, and see if it fixes your problem. Apart from this change, you
should follow the manual entry for the rest of the obj.conf
Init fn="load-modules" shlib="/path/to/server4/bin/libphp4.so"
funcs="php4_init,php4_close,php4_execute,php4_auth_trans"
Init fn="php4_init" LateInit="yes"
---------------------------------------------------------------------------
[2000-11-03 21:01:15] sniper@php.net
reclassified
---------------------------------------------------------------------------
[2000-10-04 12:41:54] lester@i-quest.com
This is the error I got when restarting iPlanet via command line after installing PHP4 w/o any
errors showing up:
conf_init: Error running init function load-modules: dlopen of /usr/netscape/server/bin/libphp4.so
failed (ld.so.1: ns-httpd: fatal: relocation error: file /usr/netscape/server/bin/libphp4.so: symbol
__pure_virtual: referenced symbol not found)
Can you give me an ideas on what's going on here? Thanks.
========================================================================
We're using the GCC2.95.2 also. After configure, make and make install, these are the steps I
did:
1. add the ff line in mime.types
type=magnus-internal/x-httpd-php exts=php
2. edit obj.conf
# note place following two lines after mime types init!
Init fn="load-modules" funcs="php4_init,php4_close,php4_execute,php4_auth_trans"
shlib="/usr/netscape/server/bin/libphp4.so"
Init fn=php4_init errorString="Failed to initialize PHP!"
<Object name="default">
.
.
. # NOTE this next line should happen after all 'ObjectType' and before all
'AddLog' lines
Service fn="php4_execute" type="magnus-internal/x-httpd-php"
.
.
</Object>
<Object name="x-httpd-php">
ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
Service fn=php4_execute
</Object>
Are these correct?
Thanks,
Lester
---------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=7016&edit=2