Bug #7016 Updated: Error when starting iPlanet

From: Date: Tue, 22 May 2001 01:25:09 +0000
Subject: Bug #7016 Updated: Error when starting iPlanet
Groups: php.dev 
Request: Send a blank email to php-dev+get-56163@lists.php.net to get a copy of this message
ID: 7016 User Update by: lester@i-quest.com Status: Closed Bug Type: iPlanet related Operating system: Solaris 7 PHP Version: 4.0.2 Description: Error when starting iPlanet I just reinstalled iPlanet w/ PHP and it's working fine now. Maybe I missed during the my first install. Thanks. Previous Comments: --------------------------------------------------------------------------- [2001-05-22 00:55:15] derick@php.net Closing because of no feedback --------------------------------------------------------------------------- [2001-04-30 16:43:29] sniper@php.net status -> feedback --------------------------------------------------------------------------- [2001-04-30 04:43:38] avsm@php.net Try the following obj.conf entry, and see if it fixes your problem. Apart from this change, you should follow the manual entry for the rest of the obj.conf Init fn="load-modules" shlib="/path/to/server4/bin/libphp4.so" funcs="php4_init,php4_close,php4_execute,php4_auth_trans" Init fn="php4_init" LateInit="yes" --------------------------------------------------------------------------- [2000-11-03 21:01:15] sniper@php.net reclassified --------------------------------------------------------------------------- [2000-10-04 12:41:54] lester@i-quest.com This is the error I got when restarting iPlanet via command line after installing PHP4 w/o any errors showing up: conf_init: Error running init function load-modules: dlopen of /usr/netscape/server/bin/libphp4.so failed (ld.so.1: ns-httpd: fatal: relocation error: file /usr/netscape/server/bin/libphp4.so: symbol __pure_virtual: referenced symbol not found) Can you give me an ideas on what's going on here? Thanks. ======================================================================== We're using the GCC2.95.2 also. After configure, make and make install, these are the steps I did: 1. add the ff line in mime.types type=magnus-internal/x-httpd-php exts=php 2. edit obj.conf # note place following two lines after mime types init! Init fn="load-modules" funcs="php4_init,php4_close,php4_execute,php4_auth_trans" shlib="/usr/netscape/server/bin/libphp4.so" Init fn=php4_init errorString="Failed to initialize PHP!" <Object name="default"> . . . # NOTE this next line should happen after all 'ObjectType' and before all 'AddLog' lines Service fn="php4_execute" type="magnus-internal/x-httpd-php" . . </Object> <Object name="x-httpd-php"> ObjectType fn="force-type" type="magnus-internal/x-httpd-php" Service fn=php4_execute </Object> Are these correct? Thanks, Lester --------------------------------------------------------------------------- The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online. Full Bug description available at: http://bugs.php.net/?id=7016

« previous php.dev (#56163) next »