Bug #11451: ODBC under Apache: DLL Initialization Failed

From: Date: Wed, 13 Jun 2001 01:03:31 +0000
Subject: Bug #11451: ODBC under Apache: DLL Initialization Failed
Groups: php.dev 
Request: Send a blank email to php-dev+get-56963@lists.php.net to get a copy of this message
From: danielc@analysisandsolutions.com Operating system: NT 4.0 SP6a PHP version: 4.0.5 PHP Bug Type: ODBC related Bug description: ODBC under Apache: DLL Initialization Failed Here's my config: Windows NT 4.0 SP6a Apache 1.3.20, Running as service "Logged On As" a particular user PHP 4.0.5 Apache and PHP runs normally. BUT, when I hit a PHP parsed page that uses ODBC connections, I get the following error message: Drwtsn32.exe - DLL Initialization Failed Initialization of the dynamic link library F:\WINNT\system32\USER32.dll failed. The process is terminating abnormally. This only happens when I have the Apache Service "Log On As" a separate user via "This Account." There's no problem if I have the Apache Service "Log On As" the "System Account." The special user account in question has full control over all files and directories in the F:\Program Files\Apache\* tree. Everyone has read access on all files and directories in the F:\WINNT\* tree. I followed the instructions in the "User Account for Apache Service to Run As (NT/2000)" section of http://httpd.apache.org/docs/win_service.html and then rebooted the machine. Still no luck. Nothing shows up in Apache's error.log. This may solely be an Apache problem, but I suspect it has to do with the interractions between PHP, ODBC and Apache. Perhaps y'all can trace what's going on. Probably the same problem reported in bug #8303: http://www.php.net/bugs.php?id=8303 Thanks, --Dan -- Edit Bug report at: http://bugs.php.net/?id=11451&edit=1

« previous php.dev (#56963) next »