Bug #11672 Updated: Apache didn´t start: SSL_CTX_set_tmp_rsa_callback
| From: | sniper@php.net | Date: | Tue, 26 Jun 2001 09:11:31 +0000 |
| Subject: | Bug #11672 Updated: Apache didn´t start: SSL_CTX_set_tmp_rsa_callback | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-58008@lists.php.net to get a copy of this message | ||
ID: 11672
Updated by: sniper
Reported By: ab@berg.net
Old-Status: Open
Status: Closed
Bug Type: Apache related
Operating system:
PHP Version: 4.0.6
Assigned To:
Comments:
There is a minor bug in PHP 4.0.6 and --with-imap-ssl
and you shouldn't even be able to complete the configure
without error. This is now fixed in CVS.
For now, workaround is to just add --with-openssl to your
configure line. (And remember to delete config.cache before
reconfiguring! And do 'make clean' after configure, before 'make')
--Jani
Previous Comments:
---------------------------------------------------------------------------
[2001-06-25 11:47:57] ab@berg.net
Hello,
My configure:
./configure
--with-mysql
--with-gd
--with-apxs
--with-jpeg-dir
--with-png-dir
--with-imap
--with-zlib-dir
--enable-sysvshm=yes
--enable-sysvsem=yes
--enable-track-vars=yes
--enable-url-includes=yes
--with-tiff-dir
--with-pdflib=/usr/local/pdflib
--enable-shared-pdflib
--with-ttf
--with-kerberos
--with-imap-ssl
My install RPM´s:
apache-devel-1.3.12-25
apache-1.3.12-25
openssl-devel-0.9.6-3
openssl-0.9.5a-14
openssl-0.9.6-3
gd-1.8.3-7
gd-devel-1.8.3-7
imap-devel-2000-9
imap-2000-9
My error when I start the Apache Webserver:
Starting httpd: Syntax error on line 236 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/libphp4.so into server: undefined symbol:
SSL_CTX_set_tmp_rsa_callback
Why doesn´t run?
Please help...
Thank you
Andreas
---------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=11672&edit=2