Bug #11665 Updated: failure to configure --with-imap-ssl

From: Date: Tue, 26 Jun 2001 13:22:41 +0000
Subject: Bug #11665 Updated: failure to configure --with-imap-ssl
Groups: php.dev 
Request: Send a blank email to php-dev+get-58060@lists.php.net to get a copy of this message
ID: 11665 User Update by: green@umdnj.edu Status: Closed Bug Type: *Install and Config Operating system: RedHat 6.2 and 7.1 PHP Version: 4.0.6 Description: failure to configure --with-imap-ssl No, configure fails no matter what explicit or implicit value used for --with-imap-ssl. Since that option test the c-client.a library, I don't see how pointing it at the openssl directory could help. Running configure with just the option (no =DIRectory) used to work as well, but doesn't now (for me). Previous Comments: --------------------------------------------------------------------------- [2001-06-26 06:47:57] sniper@php.net There was minor bug in PHP 4.0.6 but it is possible to workaround using --with-openssl as you are doing. But you are using wrong value for --with-imap-ssl as it should be the same as for --with-openssl --Jani --------------------------------------------------------------------------- [2001-06-25 10:31:24] green@umdnj.edu my config.nice is: #! /bin/sh # # Created by configure './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-ttf=/usr/local' '--with-openssl=/usr/local/ssl' '--with-imap=/products/imap/imap-2001' '--with-imap-ssl=/products/imap/imap-2001' '--with-ldap=/usr/local' '--with-mysql=/usr/local/mysql' '--with-db2=/usr/local/BerkeleyDB' '--with-gettext' '--with-mcal=/usr/local/mcal' '--enable-calendar' '--with-zlib' "$@" This will fail at the --with-imap-ssl check, with the note that the c-client.a library does not support ssl. I get the same error with the current release (4.0.6) and with 4.0.7-cvs. It did *not* happen with an earlier 4.0.6-dev version from a few weeks back (my build date: 4/27/2001), which was built with the same c-client.a file that is now being rejected. What's more, the current release and cvs builds (4.0.6 and 4.0.7-cvs), without ssl, will perform a correct logon to an imap server, but then drop the connection without logging out, causing error messages in mail.log and mail clients to fail. (I get the infamous "Command stream end of file,..." message in mail.log). I'm currently using the earlier build with (from test.php): Horde: 1.3.5-cvs IMP: 2.3.7-cvs PHP Version: 4.0.6-dev (build date 4/27/01) UWash c-client 2000c and/or 2001 OpenSSL 0.9.6 and/or 6a glibc --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=11665

« previous php.dev (#58060) next »