Bug #11363 Updated: Apache fails to start
| From: | sniper@php.net | Date: | Fri, 29 Jun 2001 03:13:08 +0000 |
| Subject: | Bug #11363 Updated: Apache fails to start | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-58444@lists.php.net to get a copy of this message | ||
ID: 11363
Updated by: sniper
Reported By: glen@designsolution.co.uk
Old-Status: Open
Status: Feedback
Bug Type: Apache related
Operating system:
PHP Version: 4.0.5
Assigned To:
Comments:
What are these constants set as in your main/php_config.h:
HAVE_SRANDOM
HAVE_SRAND48
--Jani
Previous Comments:
---------------------------------------------------------------------------
[2001-06-15 10:19:06] glen@designsolution.co.uk
Here is the output I get from gdb:
Starting program: /usr/sbin/httpd -X
Program received signal SIGFPE, Arithmetic exception.
0x2ae4c000 in php_minit_crypt (type=1, module_number=2) at
crypt.c:105
105 php_srand(time(0) * getpid() *
(php_combined_lcg() * 10000.0));
---------------------------------------------------------------------------
[2001-06-08 13:44:17] glen@designsolution.co.uk
I configured PHP4.0.5 with:
./configure --with-apxs=/usr/sbin/apxs --with-mysql=/usr
which configured fine.
I compiled and installed with no problems. When I came to
restart Apache ( version 1.3.3 ), with
/etc/rc.d/init.d/httpd restart
I get:
Shutting down http: httpd
Starting http: httpd
which usually indicates Apache has restarted okay.
However, Apache is now not running and I cannot access any
webpages on the server.
The server is a Cobalt Qube2.
Many thanks,
Glen Scott
---------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=11363&edit=2