Bug #11363 Updated: Apache fails to start
| From: | glen at designsolution dot co dot uk | Date: | Fri, 29 Jun 2001 07:59:16 +0000 |
| Subject: | Bug #11363 Updated: Apache fails to start | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-58451@lists.php.net to get a copy of this message | ||
ID: 11363
User Update by: glen@designsolution.co.uk
Status: Open
Bug Type: *Encryption and hash functions
Operating system: Cobalt OS 4.0
PHP Version: 4.0.5/6
Description: Apache fails to start
sorry, that should be
HAVE_SRANDOM 1
-Glen
Previous Comments:
---------------------------------------------------------------------------
[2001-06-29 03:57:57] glen@designsolution.co.uk
These are taken from the 4.0.6 release ( which has the same
problem as 4.0.5 ):
HAVE_RANDOM 1
HAVE_SRAND48 1
---------------------------------------------------------------------------
[2001-06-28 23:13:08] sniper@php.net
What are these constants set as in your main/php_config.h:
HAVE_SRANDOM
HAVE_SRAND48
--Jani
---------------------------------------------------------------------------
[2001-06-15 10:19:06] glen@designsolution.co.uk
Here is the output I get from gdb:
Starting program: /usr/sbin/httpd -X
Program received signal SIGFPE, Arithmetic exception.
0x2ae4c000 in php_minit_crypt (type=1, module_number=2) at
crypt.c:105
105 php_srand(time(0) * getpid() *
(php_combined_lcg() * 10000.0));
---------------------------------------------------------------------------
[2001-06-08 13:44:17] glen@designsolution.co.uk
I configured PHP4.0.5 with:
./configure --with-apxs=/usr/sbin/apxs --with-mysql=/usr
which configured fine.
I compiled and installed with no problems. When I came to
restart Apache ( version 1.3.3 ), with
/etc/rc.d/init.d/httpd restart
I get:
Shutting down http: httpd
Starting http: httpd
which usually indicates Apache has restarted okay.
However, Apache is now not running and I cannot access any
webpages on the server.
The server is a Cobalt Qube2.
Many thanks,
Glen Scott
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=11363