Bug #11679 Updated: crash on webserver start

From: Date: Mon, 02 Jul 2001 15:54:43 +0000
Subject: Bug #11679 Updated: crash on webserver start
Groups: php.dev 
Request: Send a blank email to php-dev+get-58708@lists.php.net to get a copy of this message
ID: 11679 User Update by: jbell@mcld.com Old-Status: Feedback Status: Open Bug Type: Reproducible crash Operating system: Yellow Dog Linux 2.0 - 2.2.19 PPC PHP Version: 4.0.6 Description: crash on webserver start I am not loading any of the shared libraries. Which ones do you see that are not supposed to be shared? I have tried building it again without anything shared and I get the same results. Previous Comments: --------------------------------------------------------------------------- [2001-06-27 13:49:42] sniper@php.net You are using a lot configure options that can't be 'shared'. Also, try disabling the loaded extensions one by one in php.ini to find out with which is happens on. --------------------------------------------------------------------------- [2001-06-26 09:58:52] jbell@mcld.com Here is my config line: ./configure --with-apxs=/usr/sbin/apxs --enable-pic --enable-shared --enable-inline-optimization --with-ldap=/usr --with-openssl=/usr --with-pgsql=/usr/local --with-mysql=/usr --with-imap=/usr --with-xml --with-aspell=/usr --with-gd=shared --enable-gd-native-ttf --with-png=shared --with-png-dir=/usr --with-jpeg=shared --with-jpeg-dir=/usr --with-freetype=shared --with-freetype-dir=/usr --with-zlib=shared --with-zlib-dir=/usr --with-pdflib=shared --with-readline --enable-ftp=shared --with-mcrypt=shared --with-mhash=shared --with-bz2=shared --with-db2=shared --with-db3=shared --with-kerberos=shared --with-regex=system --enable-track-vars --enable-magic-quotes --enable-debug --with-gdbm --enable-debugger --enable-sockets --enable-sysvsem --enable-sysvshm --enable-yp --enable-force-cgi-redirect --with-config-file-path=/etc/httpd/conf --------------------------------------------------------------------------- [2001-06-26 04:26:06] derick@php.net What is your configure line? --------------------------------------------------------------------------- [2001-06-25 21:02:22] jbell@mcld.com I get the following that I am unable to track down in my PHP compiling. If you can recomend any steps to help diagnoze this I woudl be glad to follow up. root@host:(/home/user/php-4.0.6)$ /sbin/service httpd restart Shutting down http: [ OK ] Starting httpd: Syntax error on line 251 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp4.so: undefined symbol: unixdriver Here is the gdb backtrace: (gdb) run -X Starting program: /usr/sbin/httpd -X Cannot access memory at address 0xe2cb3d4 (gdb) bt #0 _dl_debug_state () at dl-debug.c:56 #1 0xfe4c31c in _dl_close (_map=0x1007cf18) at dl-close.c:269 #2 0xfe4bc4c in _dl_open (file=0x10078d90 "/etc/httpd/modules/libphp4.so", mode=-2147483390, caller=0x0) at dl-open.c:407 #3 0xfe8d410 in dlopen_doit (a=0x7fffd7e8) at dlopen.c:39 #4 0x3000dcfc in _dl_catch_error (objname=0xfe9e380, errstring=0xfe9e384, operate=0xfe8d3b8 <dlopen_doit>, args=0x7fffd7e8) at dl-error.c:149 #5 0xfe8d910 in _dlerror_run (operate=0xfe8d3b8 <dlopen_doit>, args=0x7fffd7e8) at dlerror.c:130 #6 0xfe8d46c in __dlopen_check (file=0xfe6be60 "", mode=268947176) at dlopen.c:53 #7 0x10028f18 in ap_os_dso_load () #8 0x100078a8 in ap_get_server_built () #9 0x1000d888 in ap_clear_module_list () #10 0x1000e1e8 in ap_handle_command () #11 0x1000e258 in ap_srm_command_loop () #12 0x1000e89c in ap_process_resource_config () #13 0x1000f218 in ap_read_config () #14 0x1001a038 in main () #15 0xfd700f8 in __libc_start_main (argc=2, ubp_av=0x7ffffa44, ubp_ev=0x100810f0, auxvec=0x7ffffac4, rtld_fini=0xfe6be60 <main_arena>, stinfo=0x100443b0, stack_on_entry=0x3000e578) at ../sysdeps/powerpc/elf/libc-start.c:119 Thank you for your time and I look forward to your response. --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=11679

« previous php.dev (#58708) next »