Bug #11877 Updated: Apache cannot load phplib4.so

From: Date: Thu, 05 Jul 2001 07:42:35 +0000
Subject: Bug #11877 Updated: Apache cannot load phplib4.so
Groups: php.dev 
Request: Send a blank email to php-dev+get-58963@lists.php.net to get a copy of this message
ID: 11877 User Update by: dmmedia@hot.ee Old-Status: Closed Status: Open Bug Type: Compile Failure Operating system: Redhat linux 6.2 PHP Version: 4.0.6 Description: Apache cannot load phplib4.so I did so, and nothing changed. I've reinstalled imap now without kerberos support and trying to compile with it. Previous Comments: --------------------------------------------------------------------------- [2001-07-04 12:47:00] sniper@php.net 'rm config.cache ; ./configure <with your options + --with-kerberos ; make clean ; make install' --Jani --------------------------------------------------------------------------- [2001-07-04 09:52:17] dmmedia@hot.ee I tried to compile with --with-kerberos=path/to/kerberos but nothing has changed. Also phplib4.so size was the same. --------------------------------------------------------------------------- [2001-07-04 09:09:15] rasmus@php.net You need to use --with-kerberos because the version of the imap libs you are trying to link against have been linked against kerberos. --------------------------------------------------------------------------- [2001-07-04 08:48:50] dmmedia@hot.ee I've compiled php4 with: --with-apxs --with-mysql --disable-magic-quotes --enable-short-tags --with-imap And Apache said that it cannot load phplib4.so module, because of undefined symbol: gss_mech_krb5. Also I tried to add --without-kerberos --without-imap-ssl But file size was the same and Apache said the same error. --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=11877

« previous php.dev (#58963) next »