Bug #11977 Updated: no PHP.ini & failure apache loading libphp4.so
ID: 11977
Updated by: sniper
Reported By: Franck@home.nl
Old Status: Open
Status: Bogus
Old Bug Type: *Compile Issues
Bug Type: IMAP related
Operating System: Redhat 7.1 (Seawolf)
PHP Version: 4.0.6
New Comment:
the php.ini file is NOT created by configure.
It's a static file called php.ini-dist which you
should modify and copy to right place.
Also, the mxdriver error is not PHP problem but something
that is wrong with the RH 7.1 rpms. Submit a bug report to
them instead.
--Jani
Previous Comments:
------------------------------------------------------------------------
[2001-07-09 10:08:50] Franck@home.nl
I have installed PHP, but it seems that the install doesn't create a php.ini
Can't find it anywhere.
I have compiled php this way:
./configure \
"--with-apxs=/usr/sbin/apxs" \
"--with-config-file-path=/etc/php" \
"--with-gd" \
"--with-xml" \
"--with-mysql" \
"--with-zlib" \
"--enable-track-vars" \
"--enable-inline-optimization" \
"--with-gd=shared" \
"--with-mysql=/usr/local" \
"--enable-force-cgi-redirect" \
"--enable-trans-sid" \
"--enable-ftp" \
"--with-magic-quotes" \
"--with-imap" \
"--with-ldap" && make && make install
I'm also getting an error if I try to start apache:
Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/apache/libphp4.so: undefined symbol:
mxdriver
Is this a bug?
With kind regards,
Franck Nijhof
------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=11977&edit=1
Thread (2 messages)