Bug #11665 Updated: failure to configure --with-imap-ssl
| From: | green at umdnj dot edu | Date: | Sat, 21 Jul 2001 04:53:35 +0000 |
| Subject: | Bug #11665 Updated: failure to configure --with-imap-ssl | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-60462@lists.php.net to get a copy of this message | ||
ID: 11665
User updated by: green@umdnj.edu
Reported By: green@umdnj.edu
Status: Closed
Bug Type: *Install and Config
Operating System: RedHat 6.2 and 7.1
PHP Version: 4.0.6 & 4.0.7-dev
New Comment:
Okay - I think I know what was going on. Perhaps the documentation (INSTALL or README?) should have
something about this for newbies like me.
When building c-client with ssl support, you only need the archive libraries from openssl, and you
only get an archive library of c-client (c-client.a).
When php is configured as a static build, you only need the archive libraries as well (e.g.,
libssl.a). However, if you build php as a DSO object, then you also need the shared libraries
(libssl.so, etc.). Build openssl with both archive and shared libraries, and configure will pass
--with-imap-ssl.
This was not the case with earlier configure/compile cycles, so I guess I skunked myself.
Previous Comments:
------------------------------------------------------------------------
[2001-07-12 10:57:00] sniper@php.net
If you use the suggested configure options,
it will work. Also, you might need --with-kerberos.
Check the config.log for more info.
--with-openssl=/path/to/openssl
--with-imap-ssl=/path/to/openssl
--with-kerberos
--Jani
------------------------------------------------------------------------
[2001-07-11 17:33:37] green@umdnj.edu
Well, configure works okay on HPUX, but still fails on RedHat 6.2 and 7.1 (as of 7/11/01).
It doesn't matter if I use:
--with-imap-ssl,
--with-imap-ssl=/path/to/c-client, or
--with-imap-ssl=/path/to/openssl
My guess is that there's something about the default build environment on RH that's
getting in my way.
Has anyone built a current PHP (ie 4.0.7-dev) --with-imap-ssl on a RedHat install?
------------------------------------------------------------------------
[2001-06-26 09:22:40] green@umdnj.edu
No, configure fails no matter what explicit or implicit value used for --with-imap-ssl.
Since that option test the c-client.a library, I don't see how pointing it at the openssl
directory could help.
Running configure with just the option (no =DIRectory) used to work as well, but doesn't now
(for me).
------------------------------------------------------------------------
[2001-06-26 06:47:57] sniper@php.net
There was minor bug in PHP 4.0.6 but it is possible
to workaround using --with-openssl as you are doing.
But you are using wrong value for --with-imap-ssl
as it should be the same as for --with-openssl
--Jani
------------------------------------------------------------------------
[2001-06-25 10:31:24] green@umdnj.edu
my config.nice is:
#! /bin/sh
#
# Created by configure
'./configure' \
'--with-apxs=/usr/local/apache/bin/apxs' \
'--with-ttf=/usr/local' \
'--with-openssl=/usr/local/ssl' \
'--with-imap=/products/imap/imap-2001' \
'--with-imap-ssl=/products/imap/imap-2001' \
'--with-ldap=/usr/local' \
'--with-mysql=/usr/local/mysql' \
'--with-db2=/usr/local/BerkeleyDB' \
'--with-gettext' \
'--with-mcal=/usr/local/mcal' \
'--enable-calendar' \
'--with-zlib' \
"$@"
This will fail at the --with-imap-ssl check, with the note that the c-client.a library does not
support ssl. I get the same error with the current release (4.0.6) and with 4.0.7-cvs. It did
*not* happen with an earlier 4.0.6-dev version from a few weeks back (my build date: 4/27/2001),
which was built with the same c-client.a file that is now being rejected.
What's more, the current release and cvs builds (4.0.6 and 4.0.7-cvs), without ssl, will
perform a correct logon to an imap server, but then drop the connection without logging out, causing
error messages in mail.log and mail clients to fail. (I get the infamous "Command stream end
of file,..." message in mail.log).
I'm currently using the earlier build with (from test.php):
Horde: 1.3.5-cvs
IMP: 2.3.7-cvs
PHP Version: 4.0.6-dev (build date 4/27/01)
UWash c-client 2000c and/or 2001
OpenSSL 0.9.6 and/or 6a
glibc
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=11665&edit=1