Bug #12336: Unable to load dynamic library liboci8.so
| From: | Pavel dot Zakouril at mff dot cuni dot cz | Date: | Tue, 24 Jul 2001 13:26:37 +0000 |
| Subject: | Bug #12336: Unable to load dynamic library liboci8.so | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-60853@lists.php.net to get a copy of this message | ||
From: Pavel.Zakouril@mff.cuni.cz
Operating system: SCO UnixWare 7.1.1
PHP version: 4.0.6
PHP Bug Type: OCI8 related
Bug description: Unable to load dynamic library liboci8.so
I am trying to get working oci8 as a dynamic (shared) module. When I build
a static oci8 support, everything works fine. But when I switch to
dynamic:
export CC=cc; ./configure --with-oci8=shared --with-apxs -without-mysql
compilation and installations proceeds O.K., but when I try to load
liboci8.so in my PHP script, I obtain the following message:
Warning: Unable to load dynamic library
'/usr/local/lib/php/extensions/no-debug-non-zts-20001222/liboci8.so' -
dynamic linker:
/usr/local/sbin/httpd: relocation error: symbol not found: lio_listio64;
referenced from:
/u01/app/oracle/product/8.1.6/lib/libclntsh.so.8.0 in
/usr/www/mff/oratest.htm on line 26
What can be wrong ?
--
Edit bug report at: http://bugs.php.net/?id=12336&edit=1