Bug #12232 Updated: Unresolved symbol: __umoddi3
| From: | sniper@php.net | Date: | Fri, 27 Jul 2001 00:54:30 +0000 |
| Subject: | Bug #12232 Updated: Unresolved symbol: __umoddi3 | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-61140@lists.php.net to get a copy of this message | ||
ID: 12232
Updated by: sniper
Reported By: r.kalemba@mvnet.de
Old Status: Open
Status: Bogus
Bug Type: Dynamic loading
Operating System: HP 10.20
PHP Version: 4.0.6
New Comment:
Do NOT submit new bug reports about same issue, instead, re-open the first one!
Previous Comments:
------------------------------------------------------------------------
[2001-07-18 10:15:39] r.kalemba@mvnet.de
Apache 1.3.20
Mysql 3.22.32
gcc 2.8.1
PHP 4.0.6 compile:
./configure --with-mysql=/usr/local/mysql --enable-track-
vars --prefix=/usr3/php4.0.6 --enable-libgcc
--with-apxs=/usr/local/apache1320/bin/apxs
Notice:
i have modify apxs ( HPUX required .sl Suffix ! )
Start Apache -->
Error :
/usr/lib/dld.sl: Unresolved symbol: __umoddi3 (code) from
/usr/local/mysql/lib/mysql/libmysqlclient.sl.6
Syntax error on line 58 of /usr/local/apache1320/conf/httpd.test:
Cannot load /usr/local/apache1320/libexec/libphp4.sl into server: No such file or
directory
Part of config.status:
s%@CONFIGURE_COMMAND@% './configure' '--with-mysql=/usr/local/mysql'
'--enable-tra
ck-vars' '--prefix=/usr3/php4.0.6' '--enable-libgcc'
'--with-apxs=/usr/local/apach
e1319/bin/apxs'%g
s%@EXTRA_LIBS@% -lmysqlclient -lcrypt -lm -lgcc %g
s%@NATIVE_RPATHS@% -L/opt/gcc/lib/gcc-lib/hppa1.1-hp-hpux10.20/2.8.1 -L/usr/local/
mysql/lib/mysql%g
File:
-rw-rw-rw- 1 root sys 333402 Sep 15 1998 /opt/gcc/lib/gcc-lib/hppa1.1-hp-hpux10.20/
2.8.1/libgcc.a
This is the second question.
The first answer get from Asmus ( PHP-Group )
...
install php with '--enable-libgcc'
--> the same error
Have you another tip ?
R.Kalemba
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=12232&edit=1