Bug #7031 Updated: symbol ifx_checkAPI: referenced symbol not found

From: Date: Sat, 04 Aug 2001 03:14:17 +0000
Subject: Bug #7031 Updated: symbol ifx_checkAPI: referenced symbol not found
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-62038@lists.php.net to get a copy of this message
ID: 7031 Updated by: sniper Reported By: tbannister@mpathix.com Old Status: Open Status: Closed Bug Type: Dynamic loading Operating System: Solaris 2.6 PHP Version: 4.0.2 New Comment: This is fixed in CVS. http://snaps.php.net/ Previous Comments: ------------------------------------------------------------------------ [2000-10-05 03:24:16] tbannister@mpathix.com When trying to start apache I get the following error: ../bin/apachectl graceful: httpd not running, trying to start Syntax error on line 242 of /mpathix/webserver/apache/1.3.11DSO/conf/httpd.conf: Cannot load /mpathix/webserver/apache/1.3.11DSO/libexec/libphp4.so into server: ld.so.1: /mpathix/webserver/apache/1.3.11DSO/bin/httpd: fatal: relocation error: file /mpathix/informix/lib/esql/libifsql.so: symbol ifx_checkAPI: referenced sy mbol not found ../bin/apachectl graceful: httpd could not be started The symbol, ifx_checkAPI, is found in checkapi.o and although two previous bug reports ( said this was fixed, I'm seeng the Informix IDS: 7.31.UC6 Informix SDK: v2.40 uc1.1 INFORMIX-ESQL Version 9.30.UC1 Solaris 2.6 on a Sun Sparc Ultra-5 PHP 4.0.2 Apache 1.3.11 gcc v2.95.2 esql configure --with-apxs=/mpathix/webserver/apache/httpd/bin/apxs \ --with-config-file-path=/mpathix/webserver/apache/httpd/conf \ --enable-versioning \ --with-informix=yes \ --without-mysql \ --enable-track-vars ------------------------------------------------------------------------ Edit this bug report at http://bugs.php.net/?id=7031&edit=1

« previous php.dev (#62038) next »