Bug #11870 Updated: unable to load dynamic library
| From: | sniper@php.net | Date: | Sat, 11 Aug 2001 16:18:41 +0000 |
| Subject: | Bug #11870 Updated: unable to load dynamic library | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-62946@lists.php.net to get a copy of this message | ||
ID: 11870
Updated by: sniper
Reported By: serge@eclectic.nl
Old Status: Open
Status: Closed
Bug Type: IMAP related
Operating System: linux 2.2.17
PHP Version: 4.0.6
New Comment:
Fixed in CVS.
--Jani
Previous Comments:
------------------------------------------------------------------------
[2001-07-04 05:32:20] serge@eclectic.nl
When I compile php 4.0.6 as a module (so) for apache 1.3.19
everything looks ok.
even though when I try to start apache I get the following error message:
Unable to load dynamic library '/usr/local/lib/php/extensions/imap.so' -
/usr/local/lib/php/extensions/imap.so: undefined symbol: mxdriver in Unknown on line 0
I compiled php with :
--with-imap=shared
I also downloaded the laters c-client and copied the files to the location as described in the
manual.
The shared object is much smaller as the one I compiled with the previous version of php (4.0.5).
With kind regards,
Serge van Thillo
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=11870&edit=1