Bug #12831 Updated: 4.0.6 won't work with mySQL (built in support or mySQL's support)

From: Date: Sun, 19 Aug 2001 07:30:26 +0000
Subject: Bug #12831 Updated: 4.0.6 won't work with mySQL (built in support or mySQL's support)
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-63674@lists.php.net to get a copy of this message
ID: 12831 Updated by: sniper Reported By: mfurdyk@takingitglobal.org Old Status: Open Status: Feedback Bug Type: MySQL related Operating System: Linux 2.214 PHP Version: 4.0.6 New Comment: The first problem, you must have configured PHP before WITH the path. Otherwise this doesn't make any sense. Have you tried with fresh sources? ie. delete all the sources and gunzip/untar the source package ?? And what is this: --with-jpeg-dir=/usr/local/bin ??? It should be /usr/local only. Or have you really installed jpeg libs/headers with that prefix?? You second problem, the external mysql libraries. You haven't got the path to them in /etc/ld.so.conf , have you? If you don't add it, and run /sbin/ldconfig and then you should be able to start Apache. --Jani Previous Comments: ------------------------------------------------------------------------ [2001-08-18 23:23:48] mfurdyk@takingitglobal.org Here's my first configure: ./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs --with-gd --with-sablot --with-expat --with-jpeg-dir=/usr/local/bin --with-imap It stops during 'make' with this error: /bin/sh /usr/local/src/php-4.0.6/libtool --silent --mode=link gcc -I. -I/usr/local/src/php-4.0.6/ -I/usr/local/src/php-4.0.6/main -I/usr/local/src/php-4.0.6 -I/usr/local/apache/include -I/usr/local/src/php-4.0.6/Zend -I/usr/local/include -I/usr/local/src/php-4.0.6/ext/mysql/libmysql -I/usr/local/src/php-4.0.6/ext/xml/expat/xmltok -I/usr/local/src/php-4.0.6/ext/xml/expat/xmlparse -I/usr/local/src/php-4.0.6/TSRM -DLINUX=22 -DUSE_HSREGEX -DUSE_EXPAT -DSUPPORT_UTF8 -DXML_BYTE_ORDER=12 -g -O2 -o libphp4.la -rpath /usr/local/src/php-4.0.6/libs -avoid-version -L/usr/local/bin/lib -L/usr/local/lib -R /usr/local/bin/lib -R /usr/local/lib stub.lo Zend/libZend.la sapi/apache/libsapi.la main/libmain.la regex/libregex.la ext/gd/libgd.la ext/imap/libimap.la ext/mysql/libmysql.la ext/pcre/libpcre.la ext/posix/libposix.la ext/sablot/libsablot.la ext/session/libsession.la ext/standard/libstandard.la ext/xml/libxml.la TSRM/libtsrm.la -lpam -lc-client -ldl -lexpat -lsablot -lpam -lgd -ljpeg -lcrypt -lresolv -lm -ldl -lnsl -lresolv /usr/bin/ld: cannot open -lmysqlclient: No such file or directory collect2: ld returned 1 exit status make[1]: *** [libphp4.la] Error 1 If I instead configure specifying mySQL's Path: ./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs --with-gd --with-sablot --with-expat --with-jpeg-dir=/usr/local/bin --with-imap It doesn't hiccup on the first error, but instead stops during apache restart with this error: Syntax error on line 118 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/etc/httpd/libexec/libphp4.so into server: /usr/local/etc/httpd/libexec/libphp4.so: undefined symbol: mysql_field_count ------------------------------------------------------------------------ Edit this bug report at http://bugs.php.net/?id=12831&edit=1

« previous php.dev (#63674) next »