Bug #12862 Updated: Undefined symbol mysql_field_count in libphp4.so
| From: | sniper@php.net | Date: | Mon, 20 Aug 2001 16:39:05 +0000 |
| Subject: | Bug #12862 Updated: Undefined symbol mysql_field_count in libphp4.so | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-63889@lists.php.net to get a copy of this message | ||
ID: 12862
Updated by: sniper
Reported By: serge@fvrs.ru
Old Status: Closed
Status: Bogus
Bug Type: MySQL related
Operating System: Linux RH 6.2 (2.2.19)
PHP Version: 4.0.6
New Comment:
User error. :)
Previous Comments:
------------------------------------------------------------------------
[2001-08-20 12:38:11] serge@fvrs.ru
Yeah. That is. Thanks a lot.
------------------------------------------------------------------------
[2001-08-20 11:48:32] sniper@php.net
You don't happen to have the OLD libs there too?
ie. from previous Mysql installation. Try deleting
them all or install the new one someplace else.
--Jani
------------------------------------------------------------------------
[2001-08-20 11:39:50] serge@fvrs.ru
Newely installed MySQL 3.23.41 from tarball, confugured with "--prefix=/usr
--with-default-charset=koi8_ru --with-extra-charsets=all"
I try to install PHP 4.0.6 from source tar.gz. using "--with-mysql=/usr --with-apxs"
options.
No errors during compilation, but Apache won't start, reporting "undefined symbol
mysql_fileds_count in module libphp4.so".
/etc/ld.so.conf contains:
[...]
/usr/lib
/usr/lib/mysql
but this doesn't help :-)
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=12862&edit=1