Bug #12991: Wrong content type while parsing .wml files which are parsed by php

From: Date: Tue, 28 Aug 2001 07:01:56 +0000
Subject: Bug #12991: Wrong content type while parsing .wml files which are parsed by php
Groups: php.dev 
Request: Send a blank email to php-dev+get-64453@lists.php.net to get a copy of this message
From: boris@gamate.com Operating system: Linux with Apache 1.3.20 PHP version: 4.0.6 PHP Bug Type: Unknown/Other Function Bug description: Wrong content type while parsing .wml files which are parsed by php Hi there, Scenario: I added to the Apache Mime Types: text/vnd.wap.wml wml Next I set PHP to parse .wml files in apache config: AddType application/x-httpd-php .wml What I want to do ? Parsing .wml files for wap pages. What's the result ? telnet domain.com 80 GET /wap.wml HTTP/1.0 Accept: text/vnd.wap.wml <return><return> Apache/PHP returns: HTTP/1.1 200 OK Date: Tue, 28 Aug 2001 07:04:44 GMT Server: Apache/1.3.20 (Unix) PHP/4.0.6 X-Powered-By: PHP/4.0.6 Expires: Thu, 19 Nov 1981 08:52:00 GMT Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0 Pragma: no-cache Connection: close Content-Type: text/html I sent Accept: text/vnd.wap.wml and get Content-Type: text/html. That hat to return a 406 Error - not accaptable. Content Type seit in Apache Mime Config is ignored plus Accept: Header is ignored. If I set a Content-Type with the Header funktion everthing ist fine - but if not there have to be an Accept Error ! Best regards Boris -- Edit bug report at: http://bugs.php.net/?id=12991&edit=1

« previous php.dev (#64453) next »