Bug #13013 Updated: libphp4.so: undefined symbol: zendtext
| From: | sniper@php.net | Date: | Fri, 31 Aug 2001 00:08:26 +0000 |
| Subject: | Bug #13013 Updated: libphp4.so: undefined symbol: zendtext | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-64759@lists.php.net to get a copy of this message | ||
ID: 13013
Updated by: sniper
Reported By: x_ysd@yahoo.com
Status: Feedback
Bug Type: Apache related
Operating System: FreeBSD 4.2-RELEASE
PHP Version: 4.0.6
New Comment:
User feedback:
--------------
No. The latest CVS snapshot fix this problem, but
have a new one :)
% sudo /www/apache-1.3.20/bin/apachectl start
Syntax error on line 232 of
/www/apache-1.3.20/conf/httpd.conf:
Cannot load /www/apache-1.3.20/libexec/libphp4.so into
server: /www/apache-1.3.20/libexec/libphp4.so:
Undefined symbol "pcre_malloc"
^^^^^^^^^^^
/www/apache-1.3.20/bin/apachectl start: httpd could
not be started
---------------
Next time, use the web interface to reply.
Also, what was the configure line used this time?
You're most likely doing something wrong so please
include all steps you made.
Previous Comments:
------------------------------------------------------------------------
[2001-08-29 09:43:43] sniper@php.net
Does this happen with latest CVS snapshot:
http://snaps.php.net/
------------------------------------------------------------------------
[2001-08-28 22:23:35] x_ysd@yahoo.com
Hi,
This is Stone Yu. When I running php 4.0.6, I got some error messages :
% sudo /www/apache-1.3.20/bin/apachectl start
Password:
Syntax error on line 232 of /www/apache-1.3.20/conf/httpd.conf:
Cannot load /www/apache-1.3.20/libexec/libphp4.so into server:
/www/apache-1.3.20/libexec/libphp4.so: Undefined symbol "zendtext"
/www/apache-1.3.20/bin/apachectl start: httpd could not be started
O.S. : FreeBSD 4.2-RELEASE
Apache version : 1.3.20 + mod_ssl-2.8.4-1.3.20(both with DSO[max] mode)
compiler : gcc 2.95.2
I install apache + mod_ssl first, then configure and install php with DSO mode, here's my
configure parameter :
./configure --with-apxs=/www/apache-1.3.20/bin/apxs --with-config-file-path=/www/apache-1.3.20/conf
--with-mysql=/usr/local/mysql --enable-sysvsem --enable-sysvshm --with-xml --with-mod_charset
--enable-force-cgi-redirect --enable-inline-wwwimization --with-openssl=/usr/local
--enable-track-vars --with-bz2 --enable-ftp --with-gdbm=/usr/local --with-db2 --with-jpeg-dir
--with-tiff-dir --with-xpm-dir --with-ttf --with-mm --disable-posix
I also found the old php version(4.0.2) has the same bugs(bug no. #6664 & #6868), but I
can't find any solution for it.
Any suggestion will be nice, thanks a lot.
with Best Regards,
--
Stone Yu
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=13013&edit=1