Bug #1503: PHP breaks Apache 1.3.6 Auth module

From: Date: Mon, 07 Jun 1999 23:16:55 +0000
Subject: Bug #1503: PHP breaks Apache 1.3.6 Auth module
Groups: php.dev 
Request: Send a blank email to php-dev+get-6687@lists.php.net to get a copy of this message
From: paul@hyperlink.net.au Operating system: Linux 2.0.35 PHP version: 3.0.9 PHP Bug Type: Other Bug description: PHP breaks Apache 1.3.6 Auth module PHP seems to break the Apache auth module. Fault is in PHP 3.0.8 & 3.0.9 (3.0.7 is OK). Compiled PHP with --with-mysql --with-mcrypt --with-apache=../apache_1.3.6 --enable-track-vars When using the Apache config directive: <Directory /> Options Indexes FollowSymLinks Includes AllowOverride AuthConfig Limit </Directory> Apache returns an Access Denied Error when trying to access _any_ site on the server. The Apache error log is shows: [crit] [client 203.x.x.x] /.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable If we use AllowOverride None we don't get the error but we can't use authentication either (of course). PHP 3.0.7 is OK, but 3.0.8 & 3.0.9 are both affected.

« previous php.dev (#6687) next »