Re: Re: ps_mm_initialize() always called
| From: | Sascha Schumann | Date: | Fri, 05 Oct 2001 16:12:30 +0000 |
| Subject: | Re: Re: ps_mm_initialize() always called | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-67356@lists.php.net to get a copy of this message | ||
On Fri, 5 Oct 2001, Rasmus Lerdorf wrote:
> I have seen a number of people getting "Unable to start session mm module
> in Unknown on line 0" errors even when they aren't using mm as their
> session handler.
Apparently there is some potential for education.
It is simply impossible to use the MM-support in unrelated
processes, such as multiple running CGI instances. All
quoted bug-reports concern that case. I suggest to users who
don't fully understand all ramifications to ignore the
--with-mm switch.
We might make it harder for people to shoot themselves in the
foot. This could be achieved by disabling MM support in a
CGI context. This configuration should continue to work
though for debugging purposes.
- Sascha Experience IRCG
http://schumann.cx/ http://schumann.cx/ircg