Bug #13768: MySQL 4.0.0 API Broken

From: Date: Sat, 20 Oct 2001 01:33:44 +0000
Subject: Bug #13768: MySQL 4.0.0 API Broken
Groups: php.dev 
Request: Send a blank email to php-dev+get-68470@lists.php.net to get a copy of this message
From: vitaliyf@gameaholic.com Operating system: RedHat 6.2/Kernel 2.2.3 PHP version: 4.0.6 PHP Bug Type: MySQL related Bug description: MySQL 4.0.0 API Broken PHP 4.0.6 compiled with same configure parameters, but after MySQL 4.0.0 was upgraded (from 3.23.43) generated the following error on Apache's restart: Cannot load /usr/local/apache/libexec/libphp4.so into server: undefined symbol: mysql_module_entry Presumably because MySQL's API has changed and PHP hasn't been updated yet. This probably should be fixed ASAP (I thought MySQL guys were supporting MySQL extension themselves?) as I'm sure quite a few people are anxious to jump into MySQL 4.0 -- Edit bug report at: http://bugs.php.net/?id=13768&edit=1

« previous php.dev (#68470) next »