Re: Re: Bug #13788 Updated: Apache won't start because the php 4.0.6 module has a resolv error (uncompress)
| From: | Derick Rethans | Date: | Tue, 23 Oct 2001 09:25:11 +0000 |
| Subject: | Re: Re: Bug #13788 Updated: Apache won't start because the php 4.0.6 module has a resolv error (uncompress) | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-68777@lists.php.net to get a copy of this message | ||
On Tue, 23 Oct 2001, TD - Sales International Holland B.V. wrote:
> Is there anything wrong with the -lz I added to the compiler flags then or is
> it the same? It works fine far as I can tell in that way......
That would be possible too, but tweaking compiler flags is not the best
method for every user of PHP.
Derick
>
> Regards
>
> On Monday 22 October 2001 18:49, you wrote:
> > ID: 13788
> > Updated by: derick
> > Reported By: td@salesint.com
> > Old Status: Open
> > Status: Closed
> > Bug Type: MySQL related
> > Operating System: Slackware 8.0 w/ kernel 2.4.12
> > PHP Version: 4.0.6
> > New Comment:
> >
> > Already fixed in CVS.
> > You can use 4.0.6 like normal if you add --with-zlib to your configure
> > line.
> >
> > Derick
> >
> > Previous Comments:
> > ------------------------------------------------------------------------
> >
> > [2001-10-22 10:48:21] td@salesint.com
> >
> > This bug is categorized MySQL because I already found it
> > (for other OS'es and OLDER!! versions of PHP those bug
> > requests stated it should be solved) in the bug list and it
> > said it has to do with the MySQL client library. I'm using
> > 3.23.40 (The latest at this moment).
> > For short:
> > Slackware 8.0
> > Kernel 2.4.12
> > MySQL 3.23.40 (binary version)
> > PHP 4.0.6
> > Apache 1.3.20
> >
> > Error when starting Apache:
> >
> > root@linux-testbank:~# apachectl start
> > Syntax error on line 237 of /etc/apache/httpd.conf:
> > Cannot load /usr/libexec/libphp4.so into server:
> > /usr/libexec/libphp4.so: undefined symbol: uncompress
> > /usr/sbin/apachectl start: httpd could not be started
> >
> > One of the bug reports said it was fixed when editing the
> > top makefile and add -lz to the beginning of
> > LTLIBRARY_LDFLAGS I wasn't sure on what the top make file
> > was, all I can say is that I tried phpsrcdir/Makefile
> > however after a configure or whatever this file appears to
> > be copied from Makefile.in, hence, edit Makefile didn't
> > work, editing Makefile.in did work. I'm not sure about when
> > it gets copied however just using Makefile.in is garanteed
> > while Makefile isn't
> >
> >
> > ------------------------------------------------------------------------
> >
> >
> >
> > ATTENTION! Do NOT reply to this email!
> > To reply, use the web interface found at
> > http://bugs.php.net/?id=13788&edit=2
>
> --
> PHP Development Mailing List <http://www.php.net/>
> To unsubscribe, e-mail: php-dev-unsubscribe@lists.php.net
> For additional commands, e-mail: php-dev-help@lists.php.net
> To contact the list administrators, e-mail: php-list-admin@lists.php.net
>
Derick Rethans
---------------------------------------------------------------------
PHP: Scripting the Web - www.php.net - derick@php.net
SRM: Site Resource Manager - www.vl-srm.net
---------------------------------------------------------------------
JDI Media Solutions - www.jdimedia.nl - d.rethans@jdimedia.nl
Boulevard Heuvelink 102 - 6828 KT Arnhem - The Netherlands
---------------------------------------------------------------------