Bug #11151 Updated: PHP ISAPI cause ASP to malfunction under special circumstances

From: Date: Sun, 11 Nov 2001 17:10:19 +0000
Subject: Bug #11151 Updated: PHP ISAPI cause ASP to malfunction under special circumstances
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-70126@lists.php.net to get a copy of this message
ID: 11151 Updated by: sander Reported By: jstangl@itc-germany.com Old Status: Open Status: Feedback Bug Type: IIS related Operating System: Windows 2000 PHP Version: 4.0.5 New Comment: Can you try upgrading to PHP-4.0.6? Does the problem still occur? Previous Comments: ------------------------------------------------------------------------ [2001-05-28 05:56:53] jstangl@itc-germany.com We are running PHP 4.0.4/4.0.5 on W2K Server with SP1 and encountered the following problem when using ISAPI on IIS 5.0. PHP is running without problems but after browsing some PHP functions (phpinfo()) on the web server subsequently started ASP sites report the following error: -2147417842 (0x8001010e) Only restarting the web server or killing the releated dllhost.exe process resolve this problem. If the web site is running low (In process) there are no errors with ASP sites. Also if we install the php4isapi.dll as ISAPI Filter on the IIS Master properties or using the CGI mode we get no errors with APS sites. I include no gdb backtrace cause PHP is working fine. Can you confirm this problem? Are there any disadvantages in installing the PHP ISAPI filter in this environment? ------------------------------------------------------------------------ Edit this bug report at http://bugs.php.net/?id=11151&edit=1

« previous php.dev (#70126) next »