Bug #14008 Updated: $_POST/$_FILES when uploaded file is too large
| From: | sniper@php.net | Date: | Sun, 18 Nov 2001 23:31:39 +0000 |
| Subject: | Bug #14008 Updated: $_POST/$_FILES when uploaded file is too large | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-70838@lists.php.net to get a copy of this message | ||
ID: 14008
Updated by: sniper
Reported By: heyesr@php.net
Old Status: Open
Status: Closed
Bug Type: HTTP related
Operating System: RHL 7.1
PHP Version: 4.0CVS-2001-11-10
Assigned To: sniper
New Comment:
This is fixed now.
--Jani
Previous Comments:
------------------------------------------------------------------------
[2001-11-13 11:20:21] heyesr@php.net
As mentioned in irc, it segfaults now when a file is uploaded that's larger than max filesize.
Recompiling with --enable-debug didn't help, this output in error_log:
Unknown(0) : Warning - upload_max_filesize of 2097152 bytes exceeded - file [fileupload] not saved
[Tue Nov 13 17:03:56 2001] Script: '/usr/local/apache/vhtdocs/dev/test.php'
---------------------------------------
zend.c(860) : Block 0x403E107D status:
Beginning: Overrun (magic=0x646E657A, expected=0x7312F8DC)
[Tue Nov 13 17:03:56 2001] [notice] child pid 11117 exit signal Segmentation fault (11)
Backtrace produced this:
(gdb) run -X
Starting program: /www/bin/httpd -X
Program received signal SIGSEGV, Segmentation fault.
0x40138b9c in memcpy () from /lib/i686/libc.so.6
------------------------------------------------------------------------
[2001-11-10 19:48:57] sniper@php.net
Please try the latest CVS and let me know if this is good.
Also note that errors set are stored in $php_errormsg
variable if you have track_errors=on in your php.ini.
It now also sets different types for the error:
2 /* Uploaded file exceeded upload_max_filesize */
3 /* Uploaded file exceeded MAX_FILE_SIZE */
4 /* Only partiallly uploaded */
Maybe the first 2 might be same?
And we propably should have some PHP land constants for these?
------------------------------------------------------------------------
[2001-11-10 10:16:55] sniper@php.net
I'll take care of this.
--Jani
------------------------------------------------------------------------
[2001-11-10 09:42:30] heyesr@php.net
> so what do you expect?
>
> the file is to big, so it is rejected
It would be nice to get some sort of confirmation that the file was rejected and why, instead of
having to guess.
> and the submit button is most likely
> placed after the file input in the form
> so its data comes after the file data in
> the post so its behind the limit, too ...
This is just plain wrong. What about other form data that comes after the file? If I'm to
redirect the user back to the form because the file was too large, I don't want them to have to
retype stuff unnecessarily.
------------------------------------------------------------------------
[2001-11-10 09:18:51] hholzgra@php.net
so what do you expect?
the file is to big, so it is rejected
and the submit button is most likely
placed after the file input in the form
so its data comes after the file data in
the post so its behind the limit, too ...
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/?id=14008
Edit this bug report at http://bugs.php.net/?id=14008&edit=1