Bug #13467 Updated: max_execution_time not as set in php.ini
| From: | sniper@php.net | Date: | Mon, 19 Nov 2001 22:49:24 +0000 |
| Subject: | Bug #13467 Updated: max_execution_time not as set in php.ini | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-70977@lists.php.net to get a copy of this message | ||
ID: 13467
Updated by: sniper
Reported By: ian.popeck@shopsmart.com
Old Status: Open
Status: Feedback
Bug Type: Scripting Engine problem
Operating System: Solaris
PHP Version: 4.0.6
New Comment:
This should be fixed in CVS. Please try the latest
CVS snapshot from http://snaps.php.net/
Previous Comments:
------------------------------------------------------------------------
[2001-09-27 10:21:11] ian.popeck@shopsmart.com
I have a problem that seems to occur only on an occasional basis but with a number of different
scripts and modules, but it basically characterised by one thing. The script will return an error
such as
"Fatal error: Maximum execution time of 3 seconds exceeded in
/includes/third_party/Snoopy.class.inc on line 702"
.. but, the max_execution_time in the php ini file is set to 10000 which is confirmed when looking
at the output from phpinfo()
There are no calls to set_time_limit anywhere in the script and yet, the max execution time still
seems to be being ignored.
The real frustration though, is that re-running this script can often result in the error not
occuring at all.
Configure Line :
'./configure' '--with-apache=../apache_1.3.20' '--enable-track-vars'
'--without-mysql' '--with-oci8=/opt/oracle/product/8.1.7'
'--enable-sigchild'
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=13467&edit=1