Bug #14145 Updated: configure fails with apache 2.0.28
| From: | webmaster at d-s-a-g dot de | Date: | Tue, 20 Nov 2001 17:56:20 +0000 |
| Subject: | Bug #14145 Updated: configure fails with apache 2.0.28 | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-71107@lists.php.net to get a copy of this message | ||
ID: 14145
User updated by: webmaster@d-s-a-g.de
Reported By: webmaster@d-s-a-g.de
Old Status: Open
Status: Closed
Bug Type: *Configuration Issues
Operating System: linux 2.2.14
PHP Version: 4.0.6
New Comment:
i now use :
.... --with-apxs2=... and php4-latest.tar.gz
that works fine with 2.0.28
Previous Comments:
------------------------------------------------------------------------
[2001-11-20 06:59:34] webmaster@d-s-a-g.de
Hello from Berlin.
I try to build an apache with a static mod_php (on SuSE Linux 6.4 a 2.2.14 kernel)
I use this on php :
./configure --with-mysql=/usr/local/mysql --with-config-file-path=/etc --with-apache=../httpd-2_0_28
--enable-track-vars
this fails with this
<Configuring SAPI modules
<checking for AOLserver support... no
<checking for Apache module support via DSO through APXS... no
<checking for Apache module support... no
<configure: error: Invalid Apache directory - unable to find httpd.h under
/home/dantho/httpd-2_0_28
if i use "--with-apache2" wich i found i a bug report
./configure
make
make install
works fine (after using --with-apache2).
and then under httpd-2_0_28
./configure --prefix=/usr/local/httpsd --enable-ssl --with-ssl=/usr/local/openssl --enable-suexec
--with-suexec-caller=nobody --with-suexec-docroot=/home --enable-module=src/modules/php4/libphp4.a
make
make install
erverything work also fine : BUT there is not mod_php included if i check it with ./httpd -l
What goes wrong here - any idea would be great.
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=14145&edit=1