Bug #14118 Updated: Upload file more than 1 Mb doesn´t work
| From: | sniper@php.net | Date: | Wed, 21 Nov 2001 17:42:44 +0000 |
| Subject: | Bug #14118 Updated: Upload file more than 1 Mb doesn´t work | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-71272@lists.php.net to get a copy of this message | ||
ID: 14118
Updated by: sniper
Reported By: mlara@gcintl.com
Old Status: Open
Status: Feedback
Bug Type: Unknown/Other Function
Operating System: linux redhat 7.1
PHP Version: 4.0.4pl1
New Comment:
Please try with PHP 4.1.0RC3:
http://download.php.net/~zeev/php-4.1.0RC3.tar.gz
Previous Comments:
------------------------------------------------------------------------
[2001-11-20 09:16:58] mlara@gcintl.com
My php.ini has track_errors = On
but the script return the same error "The page cannot be
displayed". when I try to upload a file higher 2 Mb, I´ve changed all in my script and my
php.ini but doesn´t work, please can you help me suggest me another solution.
My script printed the post variables, if the file is lower than 2 mb the variables are printed, but
if the file is higher 2 mb I get the error "The page cannot be
displayed", and the variables aren´t printed.
Maybe my apache.conf file has a error.Please help me
Thanks
------------------------------------------------------------------------
[2001-11-19 18:43:44] sniper@php.net
This script works for me just fine. Note that to be
able to see the error message, you need to have this
directive enabled in php.ini:
track_errors = On
Also note that if MAX_FILE_SIZE is used and is set
to lower than the values in php.ini it will override them.
And the value it sets is in bytes.
--------test.php---------
<?php
print_r($HTTP_POST_FILES);
echo $php_errormsg;
?>
<FORM ENCTYPE="multipart/form-data" ACTION="test.php" METHOD=POST>
<INPUT TYPE="hidden" name="MAX_FILE_SIZE" value="1024000">
<INPUT NAME="UploadedFile" TYPE="file">
<INPUT TYPE="hidden" name="set" value="go">
<INPUT TYPE="submit" VALUE="Upload">
</FORM>
</BODY>
</HTML>
--------test.php---------
------------------------------------------------------------------------
[2001-11-19 13:59:48] mlara@gcintl.com
My apache version is: Apache/1.3.14
I use internet explorer 5.5 and netscape 4.75 but the problem persist
I erased the line <INPUT TYPE="hidden" name="MAX_FILE_SIZE"
value="1024000"> but doesn´t work.
If you see my script I print the upload variables, if I upload a file lower 2 Mb, the variables are
printed, but if I transfer a higher file the variables aren´t printed and not copy the file in
server.
Thanks
------------------------------------------------------------------------
[2001-11-19 13:36:57] cnewbill@php.net
Doesn't outright die anymore with today's (11/19) snapshot, but it still doesn't
work. Just doesn't POST anything now.
My max size 2GB, should be more than enough to cover the 9MB+ file(s) I am using to test.
-Chris
------------------------------------------------------------------------
[2001-11-19 13:21:19] cnewbill@php.net
With an older 4.2.0-dev I can get up to about 6MB.
Local File: /tmp/php4Za1Aa
Name: ecdc_v502b_up.exe
Size: 5855275
Type: application/octet-stream
Like derick said please try latest CVS and report back.
You can grab it from http://snaps.php.net/. I'll try it
myself too.
-Chris
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/?id=14118
Edit this bug report at http://bugs.php.net/?id=14118&edit=1